[ previous ] [ next ] [ threads ]
 
 From:  "Jonathan De Graeve" <Jonathan dot De dot Graeve at imelda dot be>
 To:  "Mono Dev List" <m0n0wall dash dev at lists dot m0n0 dot ch>
 Cc:  <m0n0wall at lists dot m0n0 dot ch>
 Subject:  RE: [m0n0wall] Flock browser not supported
 Date:  Wed, 12 Apr 2006 11:45:27 +0200
I traced it down to the following combination:

Mozilla based browsers AND radius mac authentication enabled and user in
radius mac list (if user is rejected from radmac and uses normal CP
login form, no problem has been found)

I sniffed the traffic and there is a stall of 10seconds (the
captiveportal_lock time) before the computer is actually logged in. If
you change the CP lock time from 10seconds to 20seconds, the computer
will simply stall for 20seconds instead of 10seconds.

I hope I can trace it down more deeply and fix it.

Affected versions:
1.21+1.22

J.


-- 
Jonathan De Graeve
Network/System Engineer
Imelda vzw
Informatica Dienst
+32 15/50.52.98
jonathan dot de dot graeve at imelda dot be

---------
Always read the manual for the correct way to do things because the
number of incorrect ways to do things is almost infinite
---------

> -----Oorspronkelijk bericht-----
> Van: Jonathan De Graeve [mailto:Jonathan dot De dot Graeve at imelda dot be]
> Verzonden: dinsdag 11 april 2006 20:31
> Aan: m0n0wall at lists dot m0n0 dot ch; Mono Dev List
> Onderwerp: [m0n0wall] Flock browser not supported
> 
> Today we ran into an issue with captive portal always disconnecting
its
> own session as 'concurrent session' and client always being
> authenticated again.
> 
> 
> 
> This with radmac enabled. The cause eventually was the 'new' browser:
> Flock.
> 
> 
> 
> So if users want to login with flock, the situation isn't supported at
> the moment.
> 
> 
> 
> J.