[ previous ] [ next ] [ threads ]
 
 From:  "Jurgen van Vliet" <jurgenvv at xs4all dot nl>
 To:  <m0n0wall dash dev at lists dot m0n0 dot ch>
 Subject:  1st basic testreport generic PC 1.3a3
 Date:  Mon, 14 Aug 2006 19:05:29 +0200
Hi Dinesh and all others working on the 1,3 alfa series,

 

Here my 1st test report of 1.3a3 , I thought lets share it J

If any of you want me to test something specific, let me know !

 

Hardware : 

 

NEXCOM NSA 1045 

Celeron 2 Ghz CPU

256 Mb mem

80 Hb IDE disk 

2 x Intel pro 1000

2x Intel pro 100

1x Atheros WIFI mini-pci Atheros 5212 chips  A/B/G 

 

Working features : 

 

1)      It boots J

2)      All NICS working 

3)      Wifi working in hostap  in G mode, 54 Mb ! no support for selecting
A channels , but that is still to be written I presume. When put on A it
went to channel 36, I presume it defaults to auto channel selection, but it
works !

4)      Captive portal works,  tested basics only without local users and
without radius auth. I see the radius additions Jonathan made in 1.23 beta
are not implemented yet

5)      firewall rules  working, only tried block all besides dns,web from
wifi to wan , block all from wifi to lan, allow all from lan to wan

6)      DNS forwarder works

7)      Blocking private network option works (had to disable it for my WAN
to work J)

8)      DHCP server works

 

Well, a lot more to test, I hope I find some more time for it.

 

Keep up the good work all !

 

Regards, 

 

Jurgen van Vliet

 

 

dmesg for reference

 

$ dmesg

Copyright (c) 1992-2005 The FreeBSD Project.

Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994

                The Regents of the University of California. All rights
reserved.

FreeBSD 6.0-STABLE #3: Mon Nov 14 14:55:43 MYT 2005

 
dinesh at prophet dot alphaque dot com:/usr/src/sys/i386/compile/M0N0WALL_GENERIC_FREEB
SD6

MPTable: <OEM00000 PROD00000000>

Timecounter "i8254" frequency 1193182 Hz quality 0

CPU: Intel(R) Celeron(R) CPU 2.00GHz (1993.54-MHz 686-class CPU)

  Origin = "GenuineIntel"  Id = 0xf29  Stepping = 9

 
Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA
,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>

  Features2=0x4400<CNTX-ID,<b14>>

real memory  = 259981312 (247 MB)

avail memory = 228208640 (217 MB)

ioapic0: Assuming intbase of 0

ioapic0 <Version 2.0> irqs 0-23 on motherboard

ath_hal: 0.9.14.9 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413)

npx0: [FAST]

npx0: <math processor> on motherboard

npx0: INT 16 interface

cpu0 on motherboard

pcib0: <MPTable Host-PCI bridge> pcibus 0 on motherboard

pci0: <PCI bus> on pcib0

pci0: <display, VGA> at device 2.0 (no driver attached)

uhci0: <Intel 82801DB (ICH4) USB controller USB-A> port 0xe100-0xe11f irq 16
at device 29.0 on pci0

uhci0: [GIANT-LOCKED]

usb0: <Intel 82801DB (ICH4) USB controller USB-A> on uhci0

usb0: USB revision 1.0

uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1

uhub0: 2 ports with 2 removable, self powered

uhci1: <Intel 82801DB (ICH4) USB controller USB-B> port 0xe000-0xe01f irq 19
at device 29.1 on pci0

uhci1: [GIANT-LOCKED]

usb1: <Intel 82801DB (ICH4) USB controller USB-B> on uhci1

usb1: USB revision 1.0

uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1

uhub1: 2 ports with 2 removable, self powered

pci0: <serial bus, USB> at device 29.7 (no driver attached)

pcib1: <MPTable PCI-PCI bridge> at device 30.0 on pci0

pci1: <PCI bus> on pcib1

pcib2: <MPTable PCI-PCI bridge> at device 7.0 on pci1

pci2: <PCI bus> on pcib2

ath0: <Atheros 5212> mem 0xec000000-0xec00ffff irq 19 at device 14.0 on pci2

ath0: Ethernet address: 00:02:6f:22:91:c8

ath0: mac 5.9 phy 4.3 radio 3.6

em0: <Intel(R) PRO/1000 Network Connection, Version - 2.1.7> port
0xd000-0xd03f mem 0xec100000-0xec11ffff,0xec120000-0xec13ffff irq 18 at
device 10.0 on pci1

em0: Ethernet address: 00:10:f3:06:ef:0e

em0:  Speed:N/A  Duplex:N/A

em1: <Intel(R) PRO/1000 Network Connection, Version - 2.1.7> port
0xd100-0xd13f mem 0xec140000-0xec15ffff,0xec160000-0xec17ffff irq 17 at
device 11.0 on pci1

em1: Ethernet address: 00:10:f3:06:ef:0f

em1:  Speed:N/A  Duplex:N/A

fxp0: <Intel 82551 Pro/100 Ethernet> port 0xd200-0xd23f mem
0xec1e0000-0xec1e0fff,0xec180000-0xec19ffff irq 16 at device 12.0 on pci1

miibus0: <MII bus> on fxp0

inphy0: <i82555 10/100 media interface> on miibus0

inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto

fxp0: Ethernet address: 00:10:f3:06:ef:10

fxp1: <Intel 82551 Pro/100 Ethernet> port 0xd300-0xd33f mem
0xec1e1000-0xec1e1fff,0xec1a0000-0xec1bffff irq 19 at device 13.0 on pci1

miibus1: <MII bus> on fxp1

inphy1: <i82555 10/100 media interface> on miibus1

inphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto

fxp1: Ethernet address: 00:10:f3:06:ef:11

isab0: <PCI-ISA bridge> at device 31.0 on pci0

isa0: <ISA bus> on isab0

atapci0: <Intel ICH4 UDMA100 controller> port
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xf000-0xf00f at device 31.1 on pci0

ata0: <ATA channel 0> on atapci0

ata1: <ATA channel 1> on atapci0

pci0: <serial bus, SMBus> at device 31.3 (no driver attached)

pmtimer0 on isa0

orm0: <ISA Option ROMs> at iomem 0xcc000-0xcffff,0xd0000-0xd0fff on isa0

atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0

atkbd0: <AT Keyboard> irq 1 on atkbdc0

kbd0 at atkbd0

atkbd0: [GIANT-LOCKED]

vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0

sc0: <System console> at flags 0x100 on isa0

sc0: VGA <16 virtual consoles, flags=0x300>

sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0

sio0: type 16550A

sio1 at port 0x2f8-0x2ff irq 3 on isa0

sio1: type 16550A

unknown: <PNP0303> can't assign resources (port)

unknown: <PNP0c01> can't assign resources (memory)

unknown: <PNP0c02> can't assign resources (memory)

unknown: <PNP0501> can't assign resources (port)

unknown: <PNP0501> can't assign resources (port)

Timecounter "TSC" frequency 1993541372 Hz quality 800

Timecounters tick every 1.000 msec

Fast IPsec: Initialized Security Association Processing.

IP Filter: v4.1.8 initialized.  Default = block all, Logging = enabled

md0: Preloaded image </mfsroot> 16777216 bytes at 0xc0902564

ad0: 39205MB <Maxtor 6E040L0 NAR61590> at ata0-master PIO4

Trying to mount root from ufs:/dev/md0