[ previous ] [ next ] [ threads ]
 
 From:  Andrew White <andywhite at gmail dot com>
 To:  Ray Soucy <rps at maine dot edu>
 Cc:  m0n0wall dash dev at lists dot m0n0 dot ch
 Subject:  Re: [m0n0wall-dev] DHCPv6 support in current beta
 Date:  Sun, 19 Jul 2009 13:01:12 +0100
Hi Ray,
Yes this works for me :-)  Don't forget to set your RA flags though

there is one bug, which is that we allow you to have a pool which has
reservations or the default gateway within it, which I should fix.  As the
server will give out from the pool and conflict with reservations.

the documentation is not accurate, the only way it would work is one
instance per interface.  I tried many different config file types including
those in the docs, but they wouldn't work for me.  I suspect the
documentation wasn't updated with the binary.

Have you experienced a problem with dhcpv6 in monowall ?

On Sun, Jul 19, 2009 at 4:41 AM, Ray Soucy <rps at maine dot edu> wrote:

> Has anyone verified that the configuration generated for dhcp6s is
> actually functional?
> I did some poking and I don't think the configuration files that are
> generated will actually work (I would need to verify this on another
> box, though).
>
> The relevant code seems to be the services_dhcp6s_configure() function
> in /etc/inc/services.inc
>
> For me, it generates something like the following:
>
> --8<--
>
> option domain-name "soucy.org";
> option domain-name-servers 2610:48:200:800:1:0:0:1;
>
>
> interface sis1 {
>       preference 255;
>       address-pool poolsis1 7200 86400;
> };
>
> pool poolsis1 {
>       range 2610:48:200:800:1:0:0:64 to 2610:48:200:800:1:0:0:C7 ;
> };
>
> host m0n0wall {
>       duid 00:00:24:cc:08:2d;
>       address 2610:48:200:800:1:0:0:1 infinity;
> };
>
> --8<--
>
> From everything I can find online, though, I believe there are a few
> errors: I think the pool information needs to be defined within an
> interface definition; I think the prefix is likely required; and I
> believe the range statement expects a / followed by the prefix size
> for the 2nd address.
>
> I've never configured dhcp6s before so I haven't verified any of this.
>
> I'm willing to do some leg work and submit a change for it if nobody
> is already working on it.  I'd just like to know if it actually works
> for others before I assume its the config that is the problem (could
> also be an issue of not joining the correct mcast group to get the
> requests).
>
> --
>
> Ray Soucy
> Communications Specialist
>
> +1 (207) 561-3526
>
> Communications and Network Services
>
> University of Maine System
> http://www.maine.edu/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: m0n0wall dash dev dash unsubscribe at lists dot m0n0 dot ch
> For additional commands, e-mail: m0n0wall dash dev dash help at lists dot m0n0 dot ch
>
>