[ previous ] [ next ] [ threads ]
 
 From:  Roberto Greiner <mrgreiner at gmail dot com>
 Cc:  m0n0wall dash dev at lists dot m0n0 dot ch
 Subject:  Re: [m0n0wall-dev] VLANs in 1.3
 Date:  Mon, 14 Dec 2009 16:09:24 -0200
Ok,

right on spot. The command made the interface work. Any idea on what I 


Hmm, probably better also to report this as a bug to Citrix, I guess....

Thanks,

Roberto Greiner



On 14/12/2009 15:50, Manuel Kasper wrote:
> On 14.12.2009, at 18:35, Roberto Greiner wrote:
>
>    


to read the packets coming out of the Monowall box, and confirmed that the packets are coming out
without any vlan tag.
>> ...
>> Is that a bug on the re driver? Monowall?
>>      
> Most likely a bug in either FreeBSD 6.4's if_re or Xen. Real-world RealTek controllers that use
the re(4) driver support hardware based VLAN tagging, and FreeBSD uses that feature if it's
available. Perhaps it's a problem in the interaction between FreeBSD and Xen? (e.g. FreeBSD thinks
the virtual NIC does "hardware" based VLAN tagging, when in fact it does not)
>
> You could try disabling VLAN hardware tagging by entering the following commands
on<http://m0n0wall/exec.php>:
>
> ifconfig re0 -vlanhwtag
> ifconfig re1 -vlanhwtag
>
> (only lasts until the next reboot)
>
> Regards,
>
> Manuel
>    


-- 
   -----------------------------------------------------
                 Marcos Roberto Greiner

    Os otimistas acham que estamos no melhor dos mundos
     Os pessimistas tem medo de que isto seja verdade
                                   James Branch Cabell
   -----------------------------------------------------