[ previous ] [ next ] [ threads ]
 From:  "David Krimmel" <dkrimmel at bcfs dot net>
 To:  <m0n0wall at lists dot m0n0 dot ch>
 Subject:  RE: [m0n0wall] m0n0 wireless interface question
 Date:  Mon, 8 Nov 2004 12:26:52 -0600
I haven't used the cards or the board before, but from your description,
I think it would be better to setup the Wireless card as an Optional
interface, "OPT1" and then bridge the card with the LAN. I am not
exactly sure if m0n0 was configured to be able to run clients on the WAN
side. I would figure you would atleast get some sort of SSID. 

Just a suggestion lookd like you hadn't tried yet.

-----Original Message-----
From: Bill Hamel [mailto:billh at bugs dot hamel dot net] 
Sent: Monday, November 08, 2004 11:18 AM
To: m0n0wall at lists dot m0n0 dot ch
Subject: [m0n0wall] m0n0 wireless interface question


Firstly, I apologize if this is a duplicate post, my laptop crashed
during the
last send , so I waited and didnt see it show up on the list, so here we
again :)

I'm having difficulty getting wireless working with m0n0wall. Any
greatly appreciated. I am trying to configure (eventually) the device as
an AP,
but can't seem to even be able to see it with netstunbler.

Hardware: Soekris Net4521, Orinico Silver 802.11b PCMCIA card (with 8.7
Firmware, have also tried 6.x) OS: Have tried M0n0wall 1.1 as well as

I looked and it seems as though the Silver cards are in the supported
list for this version M0n0wall.

In M0n0wall, I assigned the wireless card as WAN ( I have tried LAN
also)configured the card with and without WEP, gave it an SSID of "foo"
as well
as "bar" because I'getting really close to needing a drink :) Also made
sure to
"Enable" the interface.

I configured rules to allow traffic in and out (depending if the
wireless was
configured as WAN or LAN at the time).

Looking at the Kernel logs I see no errors and see the card being loaded

The card's lights act as I would suspect, a flicker every once in awhile
but the interface Status shows "No Carrier", and "Wireless Status" shows
other networks or devices even though there are when I look at

When I use Netstumbler I can't see the M0n0wall wireless network either
, but I
can see other networks as expected.

I have tried 2 different silver cards (one with Firmware 6.x and the
other with the latest 8.x).

Can anyone tell me if the Silver cards will:
A. Work, and if not what does ?
B: Is there something I am missing to configure a wireless interface on
M0n0wall using these cards ?

Many thanks in advance,


This message was sent using IMP, the Internet Messaging Program.

This message has been scanned for viruses and
dangerous content by the Bugs.Hamel.Net MailScanner, 
and appears to be clean.

To unsubscribe, e-mail: m0n0wall dash unsubscribe at lists dot m0n0 dot ch
For additional commands, e-mail: m0n0wall dash help at lists dot m0n0 dot ch