[ previous ] [ next ] [ threads ]
 
 From:  "Terry O'Connor" <coast1 at bigpond dot com>
 To:  <m0n0wall at lists dot m0n0 dot ch>
 Subject:  Problems with PPTP, Capitive Portal and Radious
 Date:  Sun, 14 Nov 2004 17:15:09 +1000
Hi guys,

I am just about at my wits end with PPTP, Captive Ports and Radius and yes I
have trawled through the archives without any luck...

I am using Monowall V1.11 on an old P1 266 MMX machine with 2 Intel Epro100
NICs and 128Mbytes of RAM.  I have a connection on the WAN interface
(203.37.203.194) to a Cisco Router which is acting as my gateway
(203.37.203.198).  The LAN interface is conencted to a PC via a Xover cable.

The basic firewall function and DHCP server is working fine ... no probs.


My problems are as follows :

When I establish a PPTP session from a host on the Internet I can establish
a session and authenitcate via the local Users database without any
problems.  When I check the IP configuration details on the Windows 2000
workstation establishing the PPTP session (ipconfig) I get :

        IPAddress 192.168.2.16
        Netmask: 255.255.255.255
        Gateway 192.168.2.16

I cannot ping anything but the local interface. I would have thought that I
could ping any host on the LAN segment.

Can anyoone help ?

The second issue is that I cannot get the Radius to authenticate either.
Radius messages are sent to the Radius Server.  I am unsure as to what the
correct Radius reply items should be for PPTP users.


The third issue is similar to the above in that I am unsure of the correct
radius reply items needed to successfully authenticate and I am unsure about
the authentication web page as every time I try to authenticate I am not
seeing any radiusd authentication requests being passed to the radiusd
server.

Can anyone help please.


Regards


Terry O'Connor