[ previous ] [ next ] [ threads ]
 
 From:  Chris Blais <cblais at watarts dot uwaterloo dot ca>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Re: [m0n0wall] can't access to a domain name which is hosted in my LAN
 Date:  Mon, 17 Jan 2005 23:42:14 -0500 (EST)
This might have already been covered but depending on your setup can't you
just work around it by modifying the hosts file on the client machines to
include things like:

192.168.1.5 mydomain.com

Kind of a pain if there's a large number of clients and it would really
only work if all of the services for mydomain.com run from the same ip.

----------------------------------------------------------
Chris R. Blais                  Department of Psychology
Ph.D. Candidate                 University of Waterloo
Cognition and Perception        200 University Avenue West
(519) 888-4567 x 5012           Waterloo, ON, N2L 3G1
Office: PAS 4042                Canada


On Mon, 17 Jan 2005, Jason wrote:

> yep loopback is what bugs me too. I have a Netget Rt314 hacked to a Zyxel
> P314 which the loopback worked on it but I ran out of port forward slots on
> the router so I needed to change.
>
> I was using clarkconnect but it ran bloody slow but it did support the
> loopback.
> ----- Original Message -----
> From: "Anthony Paul" <anthonypaul at gmail dot com>
> To: <>
> Sent: Monday, January 17, 2005 10:50 PM
> Subject: Re: [m0n0wall] can't access to a domain name which is hosted in my
> LAN
>
>
> >I have a zyxel 2x router/FW that I would love to replace with a Mono
> > box, but I host about 15 domains inside the NAT router, including DNS,
> > mail, www, etc and I can access mydomain.com from inside or outside
> > with the zyxel.
> >
> > It seems to me I can't use the dns forwarder feature of Mono due to a
> > couple of reasons.  I use AD so I have ( ? ) to use the DNS of my
> > domain controller, and secondly, the domain forwarder will just route
> > my requests to a certain IP, so I lose the header info, which many of
> > the  servivces use to figure out what to do...  i.e. the multiple
> > websites...
> >
> > I install Mono Boxes wherever I can, but unfortunately I can't have
> > one myself.  I don't plan on setting up 2 DNS servers.  The zyxel has
> > some shortcomings that frustrate me.  In general I love Mono, but this
> > loopback issue is a showstopper for me, and it appears, for many
> > others too.
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: m0n0wall dash unsubscribe at lists dot m0n0 dot ch
> > For additional commands, e-mail: m0n0wall dash help at lists dot m0n0 dot ch
> >
> >
> >
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: m0n0wall dash unsubscribe at lists dot m0n0 dot ch
> For additional commands, e-mail: m0n0wall dash help at lists dot m0n0 dot ch
>