[ previous ] [ next ] [ threads ]
 
 From:  =?koi8-r?Q?=E1=CC=C5=CB=D3=C5=CA_=EC=C9=D3=D4=C1=D2=CF=D7?= <alex at businessgrad dot ru>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  bridging and VLANs
 Date:  Fri, 4 Feb 2005 22:23:45 +0300 (MSK)
Hi, all!
I use monowal on generic PC with 3 NICs, configured like this:

-------    OPT1(xl1) ----------- LAN (xl0)
|PC1  |-------------|m0n0wall   |----------(users)
-------              -----------     NAT
 ------                  ||
|PC2   |--|              ||xl2,with configurated vlan0 (VLAN3) and vlan1
 ------   |              ||(VLAN4)interfaces vlan0 is WAN and vlan1 is OPT2
          |              ||
f0/1,     |              || f0/10 in Trunk mode
access    -------------------------
VLAN4     |Cisco Catalyst          |
           ------------------------
                 |
                 |f0/2, access VLAN3
                 v
                 Internet
So, i configured to vlans on xl2, connected to trunc interface of switch
and NAT from VLAN3 interface to xl1 works fine. But I also want configure
bridging from VLAN4 to xl1 and here is a trouble. When I PING PC2 from PC1
a have not any response, but if sniffering traffic on the PC2's NIC shwos,
that both echo requests and echo replays goes normaly, but PC1 do not get
echo replays. IN m0n0wall set unfiltered bridging between OPT2 and OPT1,
also there is firewall rules, allowing PING in both directions. If i set
bridging betwwen LAN and OPT1 it works just fine/ Where can be a trouble?
PS Sorry for my bad english
Thak you!