[ previous ] [ next ] [ threads ]
 
 From:  Jesse Guardiani <jesse at wingnet dot net>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Re: known issues with 1.2b3
 Date:  Mon, 07 Feb 2005 12:04:28 -0500
Jesse Guardiani wrote:

>> 4.) Captive Portal flakiness
>>         Captive Portal fails to honor MAC pass-through
>>         sometimes under 1.2b3. This is strange as it
>>         seems intermittent, but I've had it happen at
>>         least twice. Also, I've seen a lot of other
>>         posts regarding Captive Portal lately. Are
>>         there any other confirmed issues in 1.2b3?
> 
> No progress on this yet. I'll try to get some more concrete
> data soon.


I had this happen to me again today. My boss's laptop tried to
access the Captive Portal network. I gave him a MAC pass-through,
but it didn't work. He got no pop-up when he opened a browser,
and while he could ping other hosts on the external wireless AP
(like my laptop), he couldn't ping the m0n0wall running captive
portal. He had a lease via DHCP though. It didn't show up in the
m0n0wall because it's a static lease, so I don't know if the
m0n0wall actually assigned it to him or if it was cached in his
kernel. I had to add his static DHCP IP to the "Allowed IP addresses"
page to get him online.

I want to get to the bottom of this, but I don't know how to
go about debugging. Can someone give me some things to try
next time so I can narrow down where the problem is?

-- 
Jesse Guardiani, Systems Administrator
WingNET Internet Services,
P.O. Box 2605 // Cleveland, TN 37320-2605
423-559-LINK (v)  423-559-5145 (f)
http://www.wingnet.net