[ previous ] [ next ] [ threads ]
 
 From:  david me <david19702004 at yahoo dot com>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  [SSH] strange problem
 Date:  Thu, 17 Feb 2005 03:36:25 +0000 (GMT)
Hi alls,
I'm trying to setup a redirect incoming connections on
my NET4501 board with M0n01.2b3 for port SSH to an
internal server.
My M0n0 LAN IP is 192.168.0.1 and WAN IP (PPPoE) is
assigned dinamically and updated with DynDNS.org (so
any moment I can know the IP assigned by my ISP to the
M0n0).
The modem is ethernet as PPPoE so there is no NAT
internally at it.
Well, I assigned a new rule at Firewall NAT to accept
incoming request for post SSH and redirect to
192.168.0.10 (the other server listening on SSH).
I also add correspondent rule on Firewall Rules for
the same.
Then the test...
I used a laptop (not in the lan) with a Dialup
connection and try SSH (using PUTTY) to the m0n0wall
via port 22 unsuccessfull.
WHen I check the log of the m0n0wall, I found an
attempt to connect to the port 22 from my laptop.
Funny (probably) I found that my laptop was trying to
connect to port 22 from its port 1240!
I re-tried for 5 times (always my dialup ISP assigned
a new IP) and always the laptop results in trying to
connect from port 1240!
Why ?
I use putty since almost 4 years and when I try to ssh
I always use port 22 (ssh)!
What's wrong ?
Thank you!
David

________________________________________________________________________
Yahoo! India Matrimony: Find your partner online. http://yahoo.shaadi.com/india-matrimony/