[ previous ] [ next ] [ threads ]
 
 From:  "Lew Maggio" <lew at lsfc dot org>
 To:  <m0n0wall at lists dot m0n0 dot ch>
 Subject:  1.11 PPTP redirection not working PLEASE GOD HELP ME
 Date:  Sun, 6 Mar 2005 22:38:57 -0600
I really did it this time.  I was having trouble with the company router
so I put up a m0n0wall.  I have been running two for some time without
any problems.

 

I tried fixing it today (Sunday) and I've already had 6 phone calls
about VPN being down.  Now it's 10:30 Sunday night and I can't figure
out how to fix this before Monday morning.  When I try to connect with
VPN it is giving me a 721 error.  PPTP won't connect.

 

Here is the situation:  I have PPTP redirected from WAN to
192.168.1.202, which is a windows 2000 server.  I know the server works
because it worked with the other router and it works inside the
192.168.1.x subnet.

 

That didn't work so I added firewall rules allowing ports 1723 TCP and
GRE protocol to 192.168.1.202.  No go.

 

Then I tried adding a rule to allow TCP/UDP port 47 to 192.168.1.202,
and that didn't work either.

 

The previous router was set up this way:  1723 > 192.168.1.202 port 1723
and TCP/UDP 47 > 192.168.1.202 port 0 on that router indicating "all
ports" and it worked perfectly FOR YEARS.

 

So I tried to replicate these settings in the NAT table on m0n0wall.
Port 1723 was a no-brainer to redirect, but 47 I can't enter the way it
is supposed to be.  I enter TCP/UDP 47 but it won't let me re-direct it
to a range of ports, just one.

 

I have no idea what to do, and I'm freaking out.