[ previous ] [ next ] [ threads ]
 
 From:  "Thilo Bubek" <Thilo dot Bubek at cc dot uit dot no>
 To:  <m0n0wall at lists dot m0n0 dot ch>
 Cc:  "Thilo Bubek" <Thilo dot Bubek at cc dot uit dot no>
 Subject:  1.2b6 WEP problem
 Date:  Wed, 9 Mar 2005 10:19:54 +0100
I'm using soekris net4521-hardware and trying a Proxim 802.11b/g card (Atheros 5212) on the
WAN-interface (BSS-mode).

I get associated to an accesspoint only if I do not use WEP-encryption, with WEP-encryption and
Proxim b/g card i do not get associated to the accesspoint. Same configuration works with an Avaya
802.11b-card.

Status.php shows:

>ath0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>inet6 fe80::220:a6ff:fe50:ba13%ath0 prefixlen 64 scopeid 0x4
>inet 129.242.x.x netmask 0xffffff00 broadcast 129.242.x.x
>ether 00:20:a6:50:ba:13
>media: IEEE 802.11 Wireless Ethernet autoselect (DS/1Mbps)
>status: no carrier
>ssid xxxxxx 1:xxxxxx
>channel -1 authmode OPEN powersavemode OFF powersavesleep 100
>rtsthreshold 2312 protmode CTS
>wepmode OFF weptxkey 1

Log shows while booting:

>Jan  2 00:48:13 m0n0wall kernel: ath0: <Atheros 5212> mem 0x88000000-0x8800ffff irq 10 at device
0.0 on cardbus1
>Jan  2 00:48:13 m0n0wall kernel: ath0: mac 5.6 phy 4.1 5ghz radio 1.7 2ghz radio 2.3
>Jan  2 00:48:13 m0n0wall kernel: ath0: Ethernet address: 00:20:a6:50:ba:13
>Jan  2 00:48:13 m0n0wall kernel: ath0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps
18Mbps 24Mbps 36Mbps 48Mbps 54Mbps

Any ideas? Has anyone tried a Atheros based card in BSS-mode with WEP-encryption?

Best regards
Thilo Bubek