[ previous ] [ next ] [ threads ]
 
 From:  "Dennis" <dhosh at gaslightmedia dot com>
 To:  <m0n0wall at lists dot m0n0 dot ch>
 Subject:  RE: [m0n0wall] Can't seem to get PPTP to work
 Date:  Sat, 2 Apr 2005 23:41:12 -0500
Hello ..

Did you create a rule for it in the firewall section?
Once you've setup ppp, m0n0wall creates an additional interface in the 
drop-down boxes, when creating rules.

Dennis


-----Original Message-----
From: Ed Lentz [mailto:elentz at gmail dot com] 
Sent: Saturday, April 02, 2005 11:25 PM
To: Don Munyak
Cc: m0n0wall at lists dot m0n0 dot ch
Subject: Re: [m0n0wall] Can't seem to get PPTP to work


Chris,
Nope I cna't ping anything but the firewall, my apache server won't
respond 
either. Net use won't find the other machine either.

Don,
Where I went with the Travert and ping comment was that I was able to
follow 
the suggestions in Chapter 7 of the docs. I have added a line to my
LMhosts 
file for one of my other machines at the office, and that is the one I 
really want to get to. It is a NT box with several folders shared on the

network and it works fine. Would this be easier if I had two m0n0wall 
systems and connected them as VPN endpoints? I did have two Linksys
routers 
connected as endpoints for a time and they worked fine. I moved to
m0n0wall 
because I got several static IPs from my dsl provider and I wanted to
make 
those go to different ip devices on my lan. I'll look at that doc you
sent 
again

Ed

On Apr 2, 2005 9:36 PM, Don Munyak <don dot munyak at gmail dot com> wrote:
> 
> When I had setup the m0n0wall pptp server and added a user account, I 
> was able to connect to m0n0wall. The session stayed active and I could

> see the session detail, but I too could not ping anything on the LAN, 
> even though from the remote client doing an ipconfig /all showed that 
> I had a pptp local IP from the office.
> 
> I read from the link I sent about adding a line to the windows hosts 
> file located in c:\winnt\system32\drivers\etc. You will see something
> like:
> 
> # For example:
> #
> # 102.54.94.97 <http://102.54.94.97> 
> rhino.acme.com<http://rhino.acme.com># source server # 38.25.63.10 
> <http://38.25.63.10> x.acme.com <http://x.acme.com> # x client host
> 
> 127.0.0.1 <http://127.0.0.1> localhost
> 
> soo...for a given internal www server
> 
> 192.168.1.5 <http://192.168.1.5> office.server,local #intranet ww 
> server
> 
> Adding this will allow you to ping that workstation, but to get to the

> webpage on that workstation, I think you wil need an internal DNS.
> 
> Cheap solutions...While I am no *nix/bsd person, I know that just 
> about any downloadable distro can be configured for www and dns. 
> Likewise poptop http://www.poptop.org/ is an open-source pptp project 
> for *nix. I was thinking about loading this on a debian box to toil 
> with myself.
> 
> > I have a Mandrake linux system on the other side of the firewall and

> > I
> can't seem
> > to see it as well as the other windoze boxes.
> 
> This may because windoze boxes are prone to being wide open, while 
> your drake box has fewer ports/services open
> 
> > I can tracert and ping outside the wan from the PPTP but I can't 
> > http or
> ping inside the lan.
> 
> I am not sure I follow this.......
> 
> If I haven't answered your question. Let me know. Honestly, I am not 
> sure I understand what your asking.
> 
> - Don
> 
> On Apr 2, 2005 5:41 PM, Ed Lentz <elentz at gmail dot com> wrote:
> > That seems to work for you but I want something simple and cheap :).

> > I
> have
> > a Mandrake linux system on the other side of the firewall and I 
> > can't
> seem
> > to see it as well as the other windoze boxes. I can tracert and ping

> > outside the wan from the PPTP but I can't http or ping inside the 
> > lan. There must be a way that I am not seeing, I mean I see many 
> > messages on
> the
> > list about others getting VPN and PPTP to work.
> >
> > Ed
> >
> >
> > On Apr 2, 2005 10:57 AM, Don Munyak <don dot munyak at gmail dot com> wrote:
> > > > But, I can't seem to list or use a shared folder.
> > >
> > > from the webpage
> > http://m0n0.ch/wall/docbook/pptp-notes.html
> > >
> > > at the very bottom.
> > > Network Neighborhood in Windows does not work over PPTP 
> > > connections because broadcasts are not forwarded across the PPTP 
> > > connection.
> > >
> > > I had trouble with this as well. I may be ignorant, but I don't 
> > > see the point of creating a pptp tunnel to the router if you can't

> > > browse to a network share. Matbe I'm missing something
> > >
> > > I was able to get pptp to the m0n0wall server.
> > > Then by modifying the hosts file in the remote workstation for a 
> > > given resource...ie LAN webserver, add this to the remote hosts 
> > > file. Next time you log into m0n0wall, the remote workstation will

> > > be able to get www access to the LAN webserver.
> > >
> > > After not being able to make m0n0wall pptp server functional for 
> > > me (again, I could be missing something) I enabled the redirect to

> > > an internal MS server which was already configured for remote 
> > > access and tied in with our internal DHCP, WINS, DNS.
> > >
> > > Now by redirecting pptp to a LAN sever, we autheniticate with MS 
> > > Active Directory and have complete access to LAN resources, as 
> > > made available from MS group policies.
> > >
> > > - Don
> > >
> > > On Apr 2, 2005 9:55 AM, Ed Lentz <elentz at gmail dot com> wrote:
> > > > Hi all, I need some help here.
> > > > I am running m0n0wall ver 1.11 and set it up according to the
> chapter 7
> > > > instructions. I have my WinXP pro box at home set up as well to
> those
> > > > instructions. I can connect to the office system and I get an IP
> address
> > > > like I expect. But, I can't seem to list or use a shared folder.

> > > > I
> try
> > to
> > > > use Net use to connect to the machine and I get a "Path not 
> > > > Found"
> > message.
> > > > I modified my lmhosts file with the ip and machine name of the
> machine I
> > > > want to use. And I still get nothing. I have a rule letting all
> ports
> > thru.
> > > > Anyone have any suggestions as to why this wouldn't work?
> > > >
> > > > Another question. Would this work better with the latest Beta? I

> > > > am
> soon
> > > > getting a NET4501 to setup and I am hoping that I can load the 
> > > > new
> Bata
> > on
> > > > it.
> > > >
> > > > Thanks
> > > >
> > > > Ed
> > > >
> > > >
> > >
> >
> >
>