[ previous ] [ next ] [ threads ]
 
 From:  Raphael Maunier <raphael at maunier dot net>
 To:  Alex Threlfall <alex at cyberprog dot net>, m0n0wall at lists dot m0n0 dot ch
 Subject:  Re: [m0n0wall] Vlan problems
 Date:  Sun, 17 Apr 2005 19:30:11 +0200
Hi Alex,

This configuration work for me with my Monowall
3 Vlans on the xl0 connected to interface FastEthernet0/33

!
interface FastEthernet0/4
 description Station 1
 switchport access vlan 2
!
interface FastEthernet0/5
 description Station 2
 switchport access vlan 3
!
interface FastEthernet0/6
 description Station 3
 switchport access vlan 4
!
interface FastEthernet0/33
 duplex full
 speed 100
 switchport trunk encapsulation dot1q
 switchport mode trunk
 !



Regards,



Alex Threlfall wrote:

>Hi all,
>
>I'm trying to setup an vlan trunk from one of my fxp interfaces (fxp4 in
>this case) to an 2950-12 Switch to do vlans for other companies in this
>building.
>
>I think I've setup everything right, here's the output from my m0n0wall:
>
>$ ifconfig
>fxp0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>	inet 10.0.0.1 netmask 0xffffff00 broadcast 10.0.0.255
>	ether 00:90:27:df:03:ff
>	media: Ethernet autoselect (100baseTX <full-duplex>)
>	status: active
>fxp1: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
>	inet 82.152.104.6 netmask 0xffffffe0 broadcast 82.152.104.31
>	ether 00:50:8b:e3:b4:3c
>	media: Ethernet autoselect (10baseT/UTP)
>	status: active
>fxp2: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
>	ether 00:50:8b:e3:b4:3d
>	media: Ethernet autoselect (100baseTX <full-duplex>)
>	status: active
>fxp3: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>	inet 10.0.2.1 netmask 0xffffff00 broadcast 10.0.2.255
>	ether 00:02:a5:13:9c:7e
>	media: Ethernet autoselect (100baseTX <full-duplex>)
>	status: active
>fxp4: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 1500
>	ether 00:02:a5:13:9c:7f
>	media: Ethernet autoselect (100baseTX <full-duplex>)
>	status: active
>lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
>	inet 127.0.0.1 netmask 0xff000000 
>ppp0: flags=8010<POINTOPOINT,MULTICAST> mtu 1500
>sl0: flags=c010<POINTOPOINT,LINK2,MULTICAST> mtu 552
>faith0: flags=8002<BROADCAST,MULTICAST> mtu 1500
>vlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>	inet 10.0.3.1 netmask 0xffffff00 broadcast 10.0.3.255
>	ether 00:02:a5:13:9c:7f
>	media: Ethernet autoselect (100baseTX <full-duplex>)
>	status: active
>	vlan: 10 parent interface: fxp4
>vlan1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>	inet 10.0.4.1 netmask 0xffffff00 broadcast 10.0.4.255
>	ether 00:02:a5:13:9c:7f
>	media: Ethernet autoselect (100baseTX <full-duplex>)
>	status: active
>	vlan: 11 parent interface: fxp4
>vlan2: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
>	inet 10.0.5.1 netmask 0xffffff00 broadcast 10.0.5.255
>	ether 00:02:a5:13:9c:7f
>	media: Ethernet autoselect (100baseTX <full-duplex>)
>	status: active
>	vlan: 1 parent interface: fxp4
>ng0: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng1: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng2: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng3: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng4: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng5: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng6: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng7: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng8: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng9: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng10: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng11: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng12: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng13: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng14: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng15: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>ng16: flags=8890<POINTOPOINT,NOARP,SIMPLEX,MULTICAST> mtu 1500
>
>And this is the running-config on the switch:
>
>Current configuration : 1292 bytes
>!
>version 12.1
>no service single-slot-reload-enable
>no service pad
>service timestamps debug uptime
>service timestamps log uptime
>no service password-encryption
>!
>hostname access-sw0
>!
>enable secret 5 ***********************************
>!
>ip subnet-zero
>!
>spanning-tree extend system-id
>!
>!
>interface FastEthernet0/1
> switchport mode trunk
> no ip address
>!
>interface FastEthernet0/2
> switchport access vlan 10
> switchport mode access
> no ip address
>!
>interface FastEthernet0/3
> switchport access vlan 11
> switchport mode access
> no ip address
>!
>interface FastEthernet0/4
> no ip address
>!
>interface FastEthernet0/5
> no ip address
>!
>interface FastEthernet0/6
> no ip address
>!
>interface FastEthernet0/7
> no ip address
>!
>interface FastEthernet0/8
> no ip address
>!
>interface FastEthernet0/9
> no ip address
>!
>interface FastEthernet0/10
> no ip address
>!
>interface FastEthernet0/11
> no ip address
>!
>interface FastEthernet0/12
> no ip address
>!
>interface Vlan1
> ip address 10.0.5.2 255.255.255.0
> no ip route-cache
>!
>interface Vlan10
> ip address 10.0.3.2 255.255.255.0
> no ip route-cache
> shutdown
>!
>interface Vlan11
> ip address 10.0.4.1 255.255.255.0
> no ip route-cache
> shutdown
>!
>ip default-gateway 10.0.5.1
>ip http server
>!
>!
>line con 0
> password ***************
>line vty 0 4
> login
>line vty 5 15
> login
>!
>End
>
>Have I done something dumb here? Racking my brains for what could be the
>cause of it all :) Thought it was just the 3com swithc I was using which was
>refusing to let me use vlans, but perhaps it's my config on the m0n0wall?
>There are opt interfaces created for it with ip's set, which match the range
>that I've set in the vlan ip's.
>
>Any help would be appreciated!
>
>Kind Regards,
>
>  Alex Threlfall
>Cyberprog New Media
>tel - 0870 446 0789
>fax - 0870 446 1789 
> www.cyberprog.net
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: m0n0wall dash unsubscribe at lists dot m0n0 dot ch
>For additional commands, e-mail: m0n0wall dash help at lists dot m0n0 dot ch
>
>  
>