[ previous ] [ next ] [ threads ]
 
 From:  "M.K." <kraus at seznam dot cz>
 To:  <m0n0wall at lists dot m0n0 dot ch>
 Subject:  Re: [m0n0wall] Luis Carlos (Best firmware for Zcomax XI626 in monowall?)
 Date:  Mon, 8 Dec 2003 22:11:08 +0100
----- Original Message -----
From: "Luis Carlos de Toledo //yahoo//" <lscrlstld at yahoo dot com dot br>
To: <m0n0wall at lists dot m0n0 dot ch>
Sent: Monday, December 08, 2003 10:28 AM
Subject: Re: [m0n0wall] Best firmware for Zcomax XI626 in monowall?


> Is it prism firmware ? if it's use primary 01.01.01 and secundary 01.05.06
>
> > >Hi, know anybody witch firmware is the best - stable with monowall and
wi
> > card XI626?
> > >
> > >Thanks of your attention. Mick



Thanks Luis,

Yes, the card is with Prism chipset 2.5. I bought it with fw Primary
1.00.07, Station 1.03.06. I read that for Prism in SCENAO card is the best
1.1.1 /1.5.3, but Im not shure, if I can flash it properly to the Zcomax.
Zcomax run for the period 1 to 5 days OK. But sometime hangs moretime, in
periods of hours. I send some facts:

Monowall pb19r536 - generic pc.
By BIOS the card is detected as ID 3873, vendor 1260. HW rev: 2.0 , FW rev:
1.3.6. . PCI ports in my box uses differents IRQs.

BSD detection:.
/kernel: xl0: <3Com 3c905C-TX Fast Etherlink XL> port 0xcc00-0xcc7f mem
0xefdfff80-0xefdfffff irq 10 at device 3.0 on pci1
 /kernel: wi0: Intersil Firmware: Primary 1.00.07, Station 1.03.06
/kernel: wi0: using RF:PRISM2.5 MAC:ISL3874A(Mini-PCI)
 /kernel: wi0: 802.11 address: 00:60:b3:6b:95:62
 /kernel: wi0: <Intersil Prism2.5> mem 0xe7bff000-0xe7bfffff irq 11 at
device 2.0 on pci1
 /kernel: pci1: <PCI bus> on pcib1
/kernel: pcib1: <Intel 82801AA (ICH) Hub to PCI bridge> at device 30.0 on
pci0


Reported card is in managed mode, but other, in hostap, have similar bug.
Response on ping from box is OK usually, but the RX/TX part hangs.

Dec 5 02:20:19/kernel: wi0: wi_cmd: busy bit won't clear.
Dec 5 02:19:19/kernel: wi0: wi_cmd: busy bit won't clear.
Dec 5 02:18:14/kernel: wi0: mgmt. buffer allocation failed
Dec 5 02:18:14/kernel: wi0: failed to allocate 1594 bytes on NIC
Dec 5 02:18:14/kernel: wi0: wi_cmd: busy bit won't clear.
Dec 5 02:18:14/kernel: wi0: tx buffer allocation failed
Dec 5 02:18:14/kernel: wi0: failed to allocate 1594 bytes on NIC
Dec 5 02:18:14/kernel: wi0: wi_cmd: busy bit won't clear.
Dec 5 02:18:14/kernel: wi0: wi_cmd: busy bit won't clear.
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc80/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc24/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc23/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc28/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc85/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc01/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc2a/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc0e/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc03/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc02/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc04/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc2d/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc0c/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc09/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc06/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc84/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc83/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc81/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc00/0; last status 800b
Dec 5 02:18:14/kernel: wi0: timeout in wi_seek to fc07/0; last status 800b
Dec 5 02:18:14/kernel: wi0: init failed
Dec 5 02:18:14last message repeated 3 times
Dec 5 02:18:14/kernel: wi0: wi_cmd: busy bit won't clear.
Dec 5 02:18:14/kernel: wi0: watchdog timeout
Dec 5 02:17:09/kernel: wi0: xmit failed
Dec 5 02:17:09/kernel: wi0: timeout in wi_cmd 0x010b; event status 0x8000
Dec 5 01:45:12syslogd: exiting on signal 15

Sometime the card don't hang, but in log is:

Dec 8 20:14:40 /kernel: wi1: xmit failed
Dec 8 20:14:40 /kernel: wi1: timeout in wi_cmd 0x010b; event status 0x8000
Dec 8 18:00:55 /kernel: wi1: xmit failed
Dec 8 18:00:55 /kernel: wi1: timeout in wi_cmd 0x010b; event status 0x8000
Dec 8 14:31:11 /kernel: wi1: xmit failed
Dec 8 14:31:11 /kernel: wi1: timeout in wi_cmd 0x010b; event status 0x8000
Dec 8 12:25:30 /kernel: wi1: xmit failed
Dec 8 12:25:30 /kernel: wi1: timeout in wi_cmd 0x010b; event status 0x8000
Dec 8 11:04:07 /kernel: wi1: xmit failed
Dec 8 11:04:07 /kernel: wi1: timeout in wi_cmd 0x010b; event status 0x8000
Dec 7 22:45:26 /kernel: wi1: timeout in wi_seek to 15f/3c; last status 403c
Dec 7 19:48:48 /kernel: wi1: timeout in wi_seek to 15f/3c; last status 403c
Dec 7 16:57:10 /kernel: wi1: xmit failed
Dec 7 16:57:10 /kernel: wi1: timeout in wi_cmd 0x010b; event status 0x8000
Dec 7 15:41:41 /kernel: wi1: timeout in wi_seek to 15f/3c; last status 403c

Im not shure, if it is by firmware, can be it from noise/interference too?

                    Gracias Luis, te vayas bien   Michal