[ previous ] [ next ] [ threads ]
 
 From:  Brett Krueger <sigterm at rootednetworks dot com>
 Cc:  m0n0wall <m0n0wall at lists dot m0n0 dot ch>
 Subject:  Re: [m0n0wall] Linux pptp client
 Date:  Wed, 18 May 2005 10:42:35 -1000
I use pptpclient in linux alot actually , and with m0n0wall as well, 
when I can't do an ipsec tunnel, i suffer with pptp. But it works, for 
some reason i have to add the routes manually when i do it, even though 
pptpclient says it does.  But it works fine.

1.2b3+

Doesnt look like its sending out the password on connect for auth. 
Which.... is beyond me why.  Maybe start fresh and go from there?


-brett
High Speed Unix Hosting/Shell Services and Consulting.
http://www.rootednetworks.com


Thomas Johnson wrote:
> Just in case someone can help here is the log file from the failed 
> connection attempt.
> 
> Using interface ppp0
> Connect: ppp0 <--> /dev/pts/2
> sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x8ead127c> <pcomp> 
> <accomp>]
> rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x8ead127c> <pcomp> 
> <accomp>]
> rcvd [LCP ConfReq id=0x27 <accomp> <pcomp> <mru 1500> <magic 0x5903fd2c> 
> <auth chap MS-v2> <mrru 1600> <ssnhf> <endpoint [MAC:00:0d:b9:00:28:b0]>]
> sent [LCP ConfRej id=0x27 <mrru 1600> <ssnhf>]
> rcvd [LCP ConfReq id=0x28 <accomp> <pcomp> <mru 1500> <magic 0x5903fd2c> 
> <auth chap MS-v2>]
> sent [LCP ConfAck id=0x28 <accomp> <pcomp> <mru 1500> <magic 0x5903fd2c> 
> <auth chap MS-v2>]
> sent [LCP EchoReq id=0x0 magic=0x8ead127c]
> rcvd [CHAP Challenge id=0x1 <bb1e68275eec090aead207dce09547cd>, name = ""]
> No CHAP secret found for authenticating us to
> sent [CHAP Response id=0x1 
>
<18c26a9e27a4fa1e5ee8f1589f526b1f0000000000000000740596a9c9ff571e20ebfbd7290a44eb9a493cd25d8e250000>,

> name = "pacwilladmin"]
> rcvd [LCP EchoRep id=0x0 magic=0x5903fd2c]
> rcvd [CHAP Failure id=0x1 "E=691 R=0"]
> Unknown MS-CHAP authentication failure: E=691 R=0
> sent [LCP TermReq id=0x2 "Failed to authenticate ourselves to peer"]
> Script /usr/sbin/pptp 64.141.20.228 --nolaunchpppd finished (pid 1077), 
> status = 0x0
> Modem hangup
> Connection terminated.
> 
> 
> 
> Thomas Johnson wrote:
> 
>> I have tried connecting to the m0n0wall server with the linux 
>> pptpclient and have had limited success. Using webmin on slackware I 
>> was able to make a connection but not communicate. Using with Linspire 
>> (Debian) I can not even connect. I can connect perfectly with W2K. 
>> Does anyone have any ideas?? With the Linspire box the connection 
>> seems to fail during authentication.
>>
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: m0n0wall dash unsubscribe at lists dot m0n0 dot ch
> For additional commands, e-mail: m0n0wall dash help at lists dot m0n0 dot ch
> 
>