[ previous ] [ next ] [ threads ]
 
 From:  Ryan Hunt <dreadlocks at gmail dot com>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  BUG: Captive Portal 1.2b9
 Date:  Sun, 10 Jul 2005 19:23:50 -0500
I was running captive portal on 1.2b9 w/the built in user manager for
our local LAN party (www.wichitalan.com) yesterday, and when I added a
user with the name "40oz" it corrupted the config file. It gave me an
XML parsing error and locked me out of the web-interface.. luckily I
had a backup of the config and was able to get everything back up.. At
first I thought it was the password I entered contained illegal
characters so I tried to add the user again with a simple password and
the same thing happened again.

I believe the problem happens with a username that starts with a
number, I had added several other users that had numbers in there
username and didn't have any problem, but this was the only username
that started w/a number..

I also noted that when adding a new user the Real Name of the previous
user I added was always auto-filled in.. I don't know if this is an
intentional feature or a bug

And here is a feature request for Captive Portal, the ability for
users to create there own account..
It would make things easier for me to sign in people at our events if
when they got the captive portal page there was a form to create a
user account, where they can enter there own username/password/and
real name and it would create an account that was disabled.. then when
they came and paid for the event all I would have to do is activate
the account instead of asking them all this information and entering
it my self, because I had a couple instances where I didn't type the
username or password right and had to go in and fix it..

-Ryan