[ previous ] [ next ] [ threads ]
 
 From:  Josh Hyles <josh dot maillists at gmail dot com>
 Cc:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Re: [m0n0wall] Captive Portal Breaking
 Date:  Tue, 25 Oct 2005 17:00:01 -0400
I havent changed anything now and the unit is no long timing out. But
when I type in a good username and password, it just refreshes like i
was going to it for the first time. The URL in the address bar is in
fact the redirect address from the monowall config. I'm at a total
loss here. Could someone please tell me what a good PCI adapter + wifi
card that the monowall supports? I would like to run an external
antenna from the PCMCIA card to an omni antenna or something in my
room so i'm not just using the small built on antenna.

Thanks in advance.


On 10/25/05, Josh Hyles <josh dot maillists at gmail dot com> wrote:
> That doesnt work for me. Plus, i'm only using 1 computer at the
> moment. The whole point of this is so I dont have to have a bloody wep
> key. So i can just have mac addresses pass through for my laptop and
> have a username for my friends that come over, but still be secure
> from someone jumping on my network like my neighbor.
>
>
> On 10/25/05, Angel Javier Ripa <Angel dot Javier dot Ripa at ie dot edu> wrote:
> > I have a P3 500 with 256mb running captive portal https with more than
> > 100 users and it works fine now.
> >
> > When I installed captive portal for first time, I had a problem like
> > this. My captive portal goes down due to an excessive number of
> > concurrent connections. The maximum number of concurrent login
> > connections is 16. Some users opened several connections at the same
> > time and when mini_http process tried to send a warning page, it gone
> > down.
> >
> > Manuel Kasper sends me a mini_http revision that solve this issue. See
> > the file attached. The way to install it is:
> >
> > 1. http://monowall-ip/exec.php
> > 2. Upload the file
> > 3. Exec:        mv /usr/local/sbin/mini_httpd
> > /usr/local/sbin/mini_httpd.old
> >                 cp /tmp/mini_httpd /usr/local/sbin
> >                 chmod +x /usr/local/sbin/mini_httpd
> > 4. Restart captive portal.
> >
> > This works for me.
> >
> >
> > -----Mensaje original-----
> > De: Josh Hyles [mailto:josh dot maillists at gmail dot com]
> > Enviado el: martes, 25 de octubre de 2005 21:36
> > Para: Angel Javier Ripa
> > CC: m0n0wall at lists dot m0n0 dot ch
> > Asunto: Re: [m0n0wall] Captive Portal Breaking
> >
> > yeah. the wifi section has 10.0.1.1-254 and the m0n0wall is .254 and
> > linksys .253
> >
> > the default gateway is 10.0.1.254
> >
> >
> >
> > On 10/25/05, Angel Javier Ripa <Angel dot Javier dot Ripa at ie dot edu> wrote:
> > > Is m0n0wall the default gateway of your wireless clients?
> > >
> > > -----Mensaje original-----
> > > De: Josh Hyles [mailto:josh dot maillists at gmail dot com]
> > > Enviado el: martes, 25 de octubre de 2005 21:29
> > > Para: Jonathan De Graeve
> > > CC: Angel Javier Ripa; m0n0wall at lists dot m0n0 dot ch
> > > Asunto: Re: [m0n0wall] Captive Portal Breaking
> > >
> > > cpu is a 500mhz celeron, and when i looked at ram, it was only @ 64,
> > > so i threw another 64 in there. So its @ 128 now.
> > >
> > > something else I just noticed is that all my captive portal requests
> > > are coming from 10.0.1.253 which is the ip of the wifi (WRT54G) router
> > > the computers are connected to wirelessly. I turned off DHCP so i
> > > didnt think that router was doing anything.
> > >
> > >
> > > On 10/25/05, Jonathan De Graeve <Jonathan dot De dot Graeve at imelda dot be> wrote:
> > > > Please post this:
> > > >
> > > > CPU speed/type
> > > > Amount of memory(RAM)
> > > >
> > > > J.
> > > >
> > > > --
> > > > Jonathan De Graeve
> > > > Network/System Administrator
> > > > Imelda vzw
> > > > Informatica Dienst
> > > > 015/50.52.98
> > > > Jonathan dot de dot graeve at imelda dot be
> > > >
> > > > -----Oorspronkelijk bericht-----
> > > > Van: Josh Hyles [mailto:josh dot maillists at gmail dot com]
> > > > Verzonden: dinsdag 25 oktober 2005 20:56
> > > > Aan: Angel Javier Ripa
> > > > CC: m0n0wall at lists dot m0n0 dot ch
> > > > Onderwerp: Re: [m0n0wall] Captive Portal Breaking
> > > >
> > > > In reply to Xavier Sanz
> > > > ---Just tried that and it didnt work. As a matter of fact, the same
> > > > thing
> > > > happens. it wont even refresh the login page though, it just dies
> > > > saying my redirect url is unreachable.
> > > >
> > > > Angel
> > > > ---using 1.2 stable, internal radius, http, custom html page as
> > > > follows...
> > > >
> > > > <html>
> > > > <body bgcolor=black>
> > > > <form method="post" action="$PORTAL_ACTION$">
> > > >    <font color=red>User Name: <input name="auth_user"
> > type="text"><br>
> > > >    Password: <input name="auth_pass" type="password"><br>
> > > >    <input name="redirurl" type="hidden" value="$PORTAL_REDIRURL$">
> > > >    <input name="accept" type="submit" value="Continue">
> > > > </form>
> > > > </body>
> > > > </html>
> > > >
> > > >
> > > > On 10/25/05, Angel Javier Ripa <Angel dot Javier dot Ripa at ie dot edu> wrote:
> > > > > Which version of m0n0wall do you use? Do you use http or https?
> > > > Radius?
> > > > >
> > > > > -----Mensaje original-----
> > > > > De: Josh Hyles [mailto:josh dot maillists at gmail dot com]
> > > > > Enviado el: martes, 25 de octubre de 2005 20:29
> > > > > Para: m0n0wall at lists dot m0n0 dot ch
> > > > > Asunto: [m0n0wall] Captive Portal Breaking
> > > > >
> > > > > Sorry for the ambiguous subject line, I just couldnt think of
> > > another
> > > > > one.
> > > > > So here is my setup first off...
> > > > >
> > > > > DSL --> monowall > 3 nic (wan/lan/wifi)
> > > > >
> > > > > Wifi is setup perfect, everything works fine when captive portal
> > is
> > > > > turned
> > > > > off. When I turn on captive portal, I get the page i created
> > (login,
> > > > > password, continue button) and I type in my info and it just
> > > refreshes
> > > > > and
> > > > > will then do nothing at all and actually time out if i try and
> > type
> > > in
> > > > > my
> > > > > password again. It will then on be unaccessible for ever from what
> > > > i've
> > > > > seen
> > > > > (waited 20 min+) Any idea's?
> > > > >
> > > > >
> > > ---------------------------------------------------------------------
> > > > > To unsubscribe, e-mail: m0n0wall dash unsubscribe at lists dot m0n0 dot ch
> > > > > For additional commands, e-mail: m0n0wall dash help at lists dot m0n0 dot ch
> > > > >
> > > > >
> > > >
> > > >
> > ---------------------------------------------------------------------
> > > > To unsubscribe, e-mail: m0n0wall dash unsubscribe at lists dot m0n0 dot ch
> > > > For additional commands, e-mail: m0n0wall dash help at lists dot m0n0 dot ch
> > > >
> > > >
> > > >
> > > >
> > > >
> > >
> >
> >
> >
>