[ previous ] [ next ] [ threads ]
 
 From:  Robert Dukes <rbdukes at gmail dot com>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Mikro-tik Hotspot radius server setup help please
 Date:  Thu, 27 Oct 2005 22:53:10 +0400
Hello,
I just setup M0n0wall and would like to know how I would setup the
capitve portal to use Mikrotik hotspot raduis server to redirect my
wifi users.
My m0n0wall is nat IP for the wan from my router that is connected to my ISP
My Static IP on my  linksys router is
 85.113.211.83/24
gate 85.113.211.81
PDNS 85.113.212.75
SDNS 85.113.212.65

From the linksys to M0n0wall
Wan setting on my M0n0wall  is
IP 172.16.1.103/24
gate 172.16.1.1
PDNS 85.113.212.75
SDNS 85.113.212.65

Lan settings for use from the m0n0wall :
192.168.1.1/24




This is the setting from mikrotik for router setting

On the router
1. Enable RADIUS authentication for HotSpot users:
/ip hotspot aaa set use-radius=yes
2. To use accounting for HotSpot users on the HotSpot Manager enable this:
/ip hotspot aaa set accounting=yes
3. Set the time interval for sending accounting data to the HotSpot Manager:
/ip hotspot set interim-update=20s
4. Specify the HotSpot Manager's address as your RADIUS server:
/radius add service=hotspot address=159.148.147.194 secret=mhm timeout=2s

I had setup the raduis at Mikrotik hotspot  see my router static ip
and the dmz the DSL router is pointing  the m0n0wall dhcp ip
172.16.1.103

When I use other enternal radius everything works or from the  or the
m0n0wall captive it all works.

I think I need to to setup the fire wall rules to let uses to get
asccess to the internet IP of the Mikro hotspot server to
authinication.  But don't know what rules to setup, help would be a
big help.
--
Robert Dukes