[ previous ] [ next ] [ threads ]
 
 From:  Jack Pivac <email at delphinus dot co dot nz>
 Cc:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Re: [m0n0wall] DNS not forwarding
 Date:  Sat, 21 Jan 2006 15:27:10 +1300
Bit more information:

when i wrote "If i manually change my DNS...etc" i meant change the DNS 
server on my client PC to 202.37.101.1 instead of the 192.168.x.x 
address of monowall.... it then works. Hence me thinking its definitly a 
bug with monowall.

if i do a ping from monowall that resolves fine.

If i do a 'top' from exec.php I get the following:

$ top
last pid:   690;  load averages:  0.00,  0.01,  0.00  up 0+01:09:41    15:23:15
16 processes:  1 running, 14 sleeping, 1 zombie

Mem: 5624K Active, 4156K Inact, 6548K Wired, 8K Cache, 5264K Buf, 31M Free
Swap: 


  PID USERNAME PRI NICE  SIZE    RES STATE    TIME   WCPU    CPU COMMAND
   87 root      10   0  1456K  1224K nanslp   0:00  0.00%  0.00% ipmon
   92 root       2   0  1004K   732K select   0:00  0.00%  0.00% syslogd
  115 root       2   0  2440K  1460K select   0:00  0.00%  0.00% mpd
   95 root       2   0  2248K  1224K select   0:00  0.00%  0.00% mini_httpd
  686 root      -6  10  3952K  3300K piperd   0:00  0.00%  0.00% php
  105 root       2   0  1532K  1232K select   0:00  0.00%  0.00% snmpd
  540 root      10  10  1332K   904K wait     0:00  0.00%  0.00% sh
  139 root       3   0  1336K   904K ttyin    0:00  0.00%  0.00% sh
  109 root       2   0   896K   592K select   0:00  0.00%  0.00% choparp
  541 root       2  10  1104K   804K sbwait   0:00  0.00%  0.00% msntp
  663 nobody     2  10  1016K   784K select   0:00  0.00%  0.00% dnsmasq
  689 root      10  10  1332K   876K wait     0:00  0.00%  0.00% sh
  688 root      -6   0  2256K  1268K piperd   0:00  0.00%  0.00% mini_httpd
  668 root       2  10  1880K  1576K select   0:00  0.00%  0.00% dhcpd
  690 root      49  10  1872K   936K RUN      0:00  0.00%  0.00% top


If thats of any help?

Thanks,
Jack

Jack Pivac wrote:

> Hi everyone,
>
> Got a bit of a problem here...
> Monowall 1.21 running great, running off a hard drive.
> Static IP, manually entered my ISP's 2 DNS servers.
>
> Randomly (2nd time in a month now) it'll stop forwarding DNS queries 
> to the dns servers.
> I have a couple of records setup for my home network to make life 
> easier for myself.
>
> If i run nslookup and enter say "cale" (one of my servers) it returns 
> the correct address as per normal.
>
> If i enter say google.com it will timeout and not respond.
>
> If i manually change my DNS its using to the one entered in monowall 
> settings then it works fine.
>
> Have rebooted twice, no change.
>
> Any Ideas?
>
> Included as much log as i can if that helps....
>
> Cheers,
> Jack
>
>
>
> Jan 21 14:14:06     /kernel: DUMMYNET initialized (011031)
> Jan 21 14:14:06     mpd: [pt2] ppp node is "mpd115-pt2"
> Jan 21 14:14:06     mpd: [pt2] using interface ng3
> Jan 21 14:14:06     mpd: [pt3] ppp node is "mpd115-pt3"
> Jan 21 14:14:06     mpd: [pt3] using interface ng4
> Jan 21 14:14:06     mpd: [pt4] ppp node is "mpd115-pt4"
> Jan 21 14:14:06     mpd: [pt4] using interface ng5
> Jan 21 14:14:06     mpd: [pt5] ppp node is "mpd115-pt5"
> Jan 21 14:14:06     mpd: [pt5] using interface ng6
> Jan 21 14:14:06     mpd: [pt6] ppp node is "mpd115-pt6"
> Jan 21 14:14:06     mpd: [pt6] using interface ng7
> Jan 21 14:14:06     mpd: [pt7] ppp node is "mpd115-pt7"
> Jan 21 14:14:06     mpd: [pt7] using interface ng8
> Jan 21 14:14:06     mpd: [pt8] ppp node is "mpd115-pt8"
> Jan 21 14:14:06     mpd: [pt8] using interface ng9
> Jan 21 14:14:06     mpd: [pt9] ppp node is "mpd115-pt9"
> Jan 21 14:14:07     mpd: [pt9] using interface ng10
> Jan 21 14:14:07     mpd: [pt10] ppp node is "mpd115-pt10"
> Jan 21 14:14:07     mpd: [pt10] using interface ng11
> Jan 21 14:14:07     mpd: [pt11] ppp node is "mpd115-pt11"
> Jan 21 14:14:07     mpd: [pt11] using interface ng12
> Jan 21 14:14:07     mpd: [pt12] ppp node is "mpd115-pt12"
> Jan 21 14:14:07     mpd: [pt12] using interface ng13
> Jan 21 14:14:07     mpd: [pt13] ppp node is "mpd115-pt13"
> Jan 21 14:14:07     mpd: [pt13] using interface ng14
> Jan 21 14:14:07     mpd: [pt14] ppp node is "mpd115-pt14"
> Jan 21 14:14:07     mpd: [pt14] using interface ng15
> Jan 21 14:14:07     mpd: [pt15] ppp node is "mpd115-pt15"
> Jan 21 14:14:07     mpd: [pt15] using interface ng16
> Jan 21 14:14:09     dnsmasq[100]: reading /var/db/dhcpd.leases
> Jan 21 14:15:47     dnsmasq[100]: exiting on receipt of SIGTERM
> Jan 21 14:15:48     dhcpd: Internet Systems Consortium DHCP Server V3.0.3
> Jan 21 14:15:48     dhcpd: Copyright 2004-2005 Internet Systems 
> Consortium.
> Jan 21 14:15:48     dhcpd: All rights reserved.
> Jan 21 14:15:48     dhcpd: For info, please visit 
> http://www.isc.org/sw/dhcp/
> Jan 21 14:15:53     dnsmasq[216]: started, version 2.23 cachesize 150
> Jan 21 14:15:53     dnsmasq[216]: compile time options: IPv6 
> GNU-getopt ISC-leasefile no-DBus
> Jan 21 14:15:53     dnsmasq[216]: setting --bind-interfaces option 
> because of OS limitations
> Jan 21 14:15:53     dnsmasq[216]: setting --bind-interfaces option 
> because of OS limitations
> Jan 21 14:15:53     dnsmasq[216]: read /etc/hosts - 18 addresses
> Jan 21 14:15:53     dnsmasq[216]: reading /var/db/dhcpd.leases
> Jan 21 14:15:53     dnsmasq[216]: reading /etc/resolv.conf
> Jan 21 14:15:53     dnsmasq[216]: using nameserver 202.37.101.2#53
> Jan 21 14:15:53     dnsmasq[216]: using nameserver 202.37.101.1#53
> Jan 21 14:15:54     dhcpd: Internet Systems Consortium DHCP Server V3.0.3
> Jan 21 14:15:54     dhcpd: Copyright 2004-2005 Internet Systems 
> Consortium.
> Jan 21 14:15:54     dhcpd: All rights reserved.
> Jan 21 14:15:54     dhcpd: For info, please visit 
> http://www.isc.org/sw/dhcp/
> Jan 21 14:16:01     dnsmasq[216]: reading /var/db/dhcpd.leases
> Jan 21 14:23:20     dnsmasq[216]: reading /var/db/dhcpd.leases
>
>
>
>