[ previous ] [ next ] [ threads ]
 
 From:  genphreak <nicholas dot beams at picturesystems dot com>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Clarification of web UI: WAN PPPoE functions- is this natural or truly strange?
 Date:  Mon, 06 Feb 2006 15:24:00 +1100
Hi all,

I have a problem where my PC router (running m0n0owall CF v.1.20) drops 
the modem's PPPoE connection to my ISP and won't reconnect 
automatically.  It often takes a week or more for the WAN to drop like 
this.

m0n0wall notices the connection drop and tries to fix it (see the log 
below), but at least in some cases it simply won't reconnect until I 
login and hit reconnect or reboot the DSL modem it is controlling.

Having read the user guide and not found anything, I hoped I could ask 
the 'nobles'- as perhaps I have I misinterpreted the interface settings:

Before going any further, in the WAN UI I am running PPPoE over ADSL2 and:

- I have Dial on demand enabled (should I have this enabled for a 
permanent connection?)

- Idle Timeout is set to 0.

The router's log is detailed below, showing the disconnect and final 
connection (at the top, once I reboot the modem at 14:39.00).

The previous time this happened (not shown in this log, but I think it 
was very similar), I just hit connect in the m0n0wall web interface and 
it came back up.

Feb 5 15:39:16 	dnsmasq[4597]: reading /var/db/dhcpd.leases
Feb 5 14:40:05 	last message repeated 2 times
Feb 5 14:40:07 	mpd: [pppoe] unexpected outgoing packet, len=58
Feb 5 14:40:07 	mpd: [pppoe] unexpected outgoing packet, len=58
Feb 5 14:40:07 	mpd: [pppoe] IFACE: Up event
Feb 5 14:40:07 	mpd: [pppoe] exec: /usr/local/sbin/ppp-linkup ng0 inet 
150.101.112.88 XXX.XXX.XXX.XXX me@ispautho dns1 XXX.XXX.XXX.XXX dns2 
XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: [pppoe] exec: /sbin/route add 0.0.0.0 150.101.197.91
Feb 5 14:40:07 	mpd: [pppoe] exec: /sbin/route add XXX.XXX.XXX.XXX 
-iface lo0
Feb 5 14:40:07 	mpd: [pppoe] exec: /sbin/ifconfig ng0 XXX.XXX.XXX.XXX 
150.101.197.91 netmask 0xffffffff -link0
Feb 5 14:40:07 	mpd: [pppoe] setting interface ng0 MTU to 1492 bytes
Feb 5 14:40:07 	mpd: [pppoe] exec: /sbin/ifconfig ng0 down delete -link0
Feb 5 14:40:07 	mpd: [pppoe] exec: /sbin/route delete XXX.XXX.XXX.XXX 
-iface lo0
Feb 5 14:40:07 	mpd: [pppoe] exec: /sbin/route delete 0.0.0.0 150.101.197.90
Feb 5 14:40:07 	mpd: [pppoe] IFACE: Up event
Feb 5 14:40:07 	mpd: XXX.XXX.XXX.XXX -> XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: [pppoe] IPCP: LayerUp
Feb 5 14:40:07 	mpd: [pppoe] IPCP: state change Ack-Sent --> Opened
Feb 5 14:40:07 	mpd: SECDNS XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: PRIDNS XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: IPADDR XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: [pppoe] IPCP: rec'd Configure Ack #89 link 0 (Ack-Sent)
Feb 5 14:40:07 	mpd: SECDNS XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: PRIDNS XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: IPADDR XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: [pppoe] IPCP: SendConfigReq #89
Feb 5 14:40:07 	mpd: SECDNS XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: PRIDNS XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: XXX.XXX.XXX.XXX is OK
Feb 5 14:40:07 	mpd: IPADDR XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: [pppoe] IPCP: rec'd Configure Nak #88 link 0 (Ack-Sent)
Feb 5 14:40:07 	mpd: SECDNS 0.0.0.0
Feb 5 14:40:07 	mpd: PRIDNS 0.0.0.0
Feb 5 14:40:07 	mpd: IPADDR 0.0.0.0
Feb 5 14:40:07 	mpd: [pppoe] IPCP: SendConfigReq #88
Feb 5 14:40:07 	mpd: COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
Feb 5 14:40:07 	mpd: [pppoe] IPCP: rec'd Configure Reject #87 link 0 
(Ack-Sent)
Feb 5 14:40:07 	mpd: [pppoe] IPCP: state change Req-Sent --> Ack-Sent
Feb 5 14:40:07 	mpd: IPADDR XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: [pppoe] IPCP: SendConfigAck #1
Feb 5 14:40:07 	mpd: XXX.XXX.XXX.XXX is OK
Feb 5 14:40:07 	mpd: IPADDR XXX.XXX.XXX.XXX
Feb 5 14:40:07 	mpd: [pppoe] IPCP: rec'd Configure Request #1 link 0 
(Req-Sent)
Feb 5 14:40:07 	mpd: SECDNS 0.0.0.0
Feb 5 14:40:07 	mpd: PRIDNS 0.0.0.0
Feb 5 14:40:07 	mpd: COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
Feb 5 14:40:07 	mpd: IPADDR 0.0.0.0
Feb 5 14:40:07 	mpd: [pppoe] IPCP: SendConfigReq #87
Feb 5 14:40:07 	mpd: [pppoe] IPCP: state change Starting --> Req-Sent
Feb 5 14:40:07 	mpd: [pppoe] IPCP: Up event
Feb 5 14:40:07 	mpd: [pppoe] up: 1 link, total bandwidth 64000 bps
Feb 5 14:40:07 	mpd: [pppoe] setting interface ng0 MTU to 1492 bytes
Feb 5 14:40:07 	mpd: [pppoe] LCP: phase shift AUTHENTICATE --> NETWORK
Feb 5 14:40:07 	mpd: [pppoe] LCP: authorization successful
Feb 5 14:40:07 	mpd: [pppoe] CHAP: rec'd SUCCESS #1
Feb 5 14:40:07 	mpd: [pppoe] CHAP: sending RESPONSE
Feb 5 14:40:07 	mpd: Using authname "me@ispautho"
Feb 5 14:40:07 	mpd: Name: "lns2.rtr5"
Feb 5 14:40:07 	mpd: [pppoe] CHAP: rec'd CHALLENGE #1
Feb 5 14:40:07 	mpd: [pppoe] LCP: LayerUp
Feb 5 14:40:07 	mpd: [pppoe] LCP: auth: peer wants CHAP, I want nothing
Feb 5 14:40:07 	mpd: [pppoe] LCP: phase shift ESTABLISH --> AUTHENTICATE
Feb 5 14:40:07 	mpd: [pppoe] LCP: state change Ack-Rcvd --> Opened
Feb 5 14:40:07 	mpd: MAGICNUM f31d7366
Feb 5 14:40:07 	mpd: AUTHPROTO CHAP MD5
Feb 5 14:40:07 	mpd: MRU 1492
Feb 5 14:40:07 	mpd: [pppoe] LCP: SendConfigAck #2
Feb 5 14:40:07 	mpd: MAGICNUM f31d7366
Feb 5 14:40:07 	mpd: AUTHPROTO CHAP MD5
Feb 5 14:40:07 	mpd: MRU 1492
Feb 5 14:40:07 	mpd: [pppoe] LCP: rec'd Configure Request #2 link 0 
(Ack-Rcvd)
Feb 5 14:40:05 	mpd: [pppoe] LCP: state change Req-Sent --> Ack-Rcvd
Feb 5 14:40:05 	mpd: MAGICNUM 3ff24760
Feb 5 14:40:05 	mpd: MRU 1492
Feb 5 14:40:05 	mpd: [pppoe] LCP: rec'd Configure Ack #165 link 0 (Req-Sent)
Feb 5 14:40:05 	mpd: MAGICNUM 3ff24760
Feb 5 14:40:05 	mpd: MRU 1492
Feb 5 14:40:05 	mpd: [pppoe] LCP: SendConfigReq #165
Feb 5 14:40:05 	mpd: [pppoe] LCP: phase shift DEAD --> ESTABLISH
Feb 5 14:40:05 	mpd: [pppoe] LCP: state change Starting --> Req-Sent
Feb 5 14:40:05 	mpd: [pppoe] LCP: Up event
Feb 5 14:40:05 	mpd: [pppoe] link: origination is local
Feb 5 14:40:05 	mpd: [pppoe] link: UP event
Feb 5 14:40:05 	mpd: [pppoe] rec'd proto LCP while dead
Feb 5 14:40:05 	mpd: [pppoe] device is now in state UP
Feb 5 14:40:05 	mpd: [pppoe] device: UP event in state OPENING
Feb 5 14:40:05 	mpd: [pppoe] PPPoE connection successful
Feb 5 14:40:05 	/kernel: session in wrong state
Feb 5 14:40:05 	mpd: [pppoe] rec'd ACNAME "lns2.syd7"
Feb 5 14:40:05 	mpd: [pppoe] device is now in state OPENING
Feb 5 14:40:05 	mpd: [pppoe] device: OPEN event in state DOWN
Feb 5 14:39:59 	mpd: [pppoe] device is now in state DOWN
Feb 5 14:39:59 	mpd: [pppoe] pausing 6 seconds before open
Feb 5 14:39:59 	mpd: [pppoe] device: OPEN event in state DOWN
Feb 5 14:39:59 	mpd: [pppoe] LCP: Down event
Feb 5 14:39:59 	mpd: [pppoe] link: DOWN event
Feb 5 14:39:59 	mpd: [pppoe] device is now in state DOWN
Feb 5 14:39:59 	mpd: [pppoe] device: DOWN event in state OPENING
Feb 5 14:39:59 	mpd: [pppoe] PPPoE connection timeout after 9 seconds
Feb 5 14:39:50 	mpd: [pppoe] device is now in state OPENING
Feb 5 14:39:50 	mpd: [pppoe] device: OPEN event in state DOWN
Feb 5 14:39:44 	mpd: [pppoe] device is now in state DOWN
Feb 5 14:39:44 	mpd: [pppoe] pausing 6 seconds before open
Feb 5 14:39:44 	mpd: [pppoe] device: OPEN event in state DOWN
Feb 5 14:39:44 	mpd: [pppoe] LCP: Down event
Feb 5 14:39:44 	mpd: [pppoe] link: DOWN event
Feb 5 14:39:44 	mpd: [pppoe] device is now in state DOWN
Feb 5 14:39:44 	mpd: [pppoe] device: DOWN event in state OPENING
Feb 5 14:39:44 	mpd: [pppoe] PPPoE connection timeout after 9 seconds
Feb 5 14:39:35 	mpd: [pppoe] device is now in state OPENING
Feb 5 14:39:35 	mpd: [pppoe] device: OPEN event in state DOWN
Feb 5 14:39:29 	mpd: [pppoe] device is now in state DOWN
Feb 5 14:39:29 	mpd: [pppoe] pausing 6 seconds before open
Feb 5 14:39:29 	mpd: [pppoe] device: OPEN event in state DOWN
Feb 5 14:39:29 	mpd: [pppoe] LCP: Down event
Feb 5 14:39:29 	mpd: [pppoe] link: DOWN event
Feb 5 14:39:29 	mpd: [pppoe] device is now in state DOWN
Feb 5 14:39:29 	mpd: [pppoe] device: DOWN event in state OPENING
Feb 5 14:39:29 	mpd: [pppoe] PPPoE connection timeout after 9 seconds
Feb 5 14:39:20 	mpd: [pppoe] device is now in state OPENING
Feb 5 14:39:20 	mpd: [pppoe] device: OPEN event in state DOWN
Feb 5 14:39:20 	mpd: [pppoe] LCP: LayerStart
Feb 5 14:39:20 	mpd: [pppoe] LCP: state change Initial --> Starting
Feb 5 14:39:20 	mpd: [pppoe] LCP: Open event
Feb 5 14:39:20 	mpd: [pppoe] link: OPEN event
Feb 5 14:39:20 	mpd: [pppoe] opening link "pppoe"...
Feb 5 14:39:20 	mpd: [pppoe] bundle: OPEN event in state CLOSED
Feb 5 14:39:20 	mpd: [pppoe] IPCP: LayerStart
Feb 5 14:39:20 	mpd: [pppoe] IPCP: state change Initial --> Starting
Feb 5 14:39:20 	mpd: [pppoe] IPCP: Open event
Feb 5 14:39:20 	mpd: [pppoe] outgoing packet is demand
Feb 5 14:39:20 	dnsmasq[4597]: reading /var/db/dhcpd.leases
Feb 5 11:18:53 	mpd: [pppoe] LCP: Down event
Feb 5 11:18:53 	mpd: [pppoe] link: DOWN event
Feb 5 11:18:53 	mpd: [pppoe] device is now in state DOWN
Feb 5 11:18:53 	mpd: [pppoe] device: DOWN event in state OPENING
Feb 5 11:18:53 	mpd: [pppoe] PPPoE connection timeout after 9 seconds
Feb 5 11:18:44 	mpd: [pppoe] device is now in state OPENING
Feb 5 11:18:44 	mpd: [pppoe] device: OPEN event in state DOWN
Feb 5 11:18:42 	mpd: [pppoe] device is now in state DOWN
Feb 5 11:18:42 	mpd: [pppoe] pausing 2 seconds before open
Feb 5 11:18:42 	mpd: [pppoe] device: OPEN event in state DOWN
Feb 5 11:18:38 	mpd: [pppoe] device is now in state DOWN
Feb 5 11:18:38 	mpd: [pppoe] pausing 4 seconds before open
Feb 5 11:18:38 	mpd: [pppoe] device: OPEN event in state DOWN
Feb 5 11:18:38 	mpd: [pppoe] device is now in state DOWN
Feb 5 11:18:38 	mpd: [pppoe] device: CLOSE event in state DOWN
Feb 5 11:18:38 	mpd: [pppoe] LCP: Down event
Feb 5 11:18:38 	mpd: [pppoe] link: DOWN event
Feb 5 11:18:38 	mpd: [pppoe] device is now in state DOWN
Feb 5 11:18:38 	mpd: [pppoe] device: DOWN event in state CLOSING
Feb 5 11:18:38 	mpd: [pppoe] device is now in state CLOSING
Feb 5 11:18:38 	mpd: [pppoe] device: OPEN event in state CLOSING
Feb 5 11:18:38 	mpd: [pppoe] LCP: LayerFinish
Feb 5 11:18:38 	mpd: [pppoe] LCP: state change Starting --> Initial
Feb 5 11:18:38 	mpd: [pppoe] LCP: Close event
Feb 5 11:18:38 	mpd: [pppoe] link: CLOSE event
Feb 5 11:18:38 	mpd: [pppoe] device is now in state CLOSING
Feb 5 11:18:38 	mpd: [pppoe] device: CLOSE event in state UP
Feb 5 11:18:38 	mpd: [pppoe] closing link "pppoe"...
Feb 5 11:18:38 	mpd: [pppoe] bundle: CLOSE event in state OPENED
Feb 5 11:18:38 	mpd: [pppoe] LCP: LayerDown
Feb 5 11:18:38 	mpd: [pppoe] IPCP: LayerFinish
Feb 5 11:18:38 	mpd: [pppoe] IPCP: state change Starting --> Initial
Feb 5 11:18:38 	mpd: [pppoe] IPCP: Close event
Feb 5 11:18:38 	mpd: [pppoe] exec: /sbin/ifconfig ng0 link0
Feb 5 11:18:38 	mpd: [pppoe] IFACE: Down event
Feb 5 11:18:38 	mpd: [pppoe] IPCP: LayerDown
Feb 5 11:18:38 	mpd: [pppoe] IPCP: state change Opened --> Starting
Feb 5 11:18:38 	mpd: [pppoe] IPCP: Down event
Feb 5 11:18:38 	mpd: [pppoe] up: 0 links, total bandwidth 9600 bps
Feb 5 11:18:38 	mpd: [pppoe] setting interface ng0 MTU to 1500 bytes
Feb 5 11:18:38 	mpd: [pppoe] LCP: phase shift NETWORK --> DEAD
Feb 5 11:18:38 	mpd: [pppoe] LCP: state change Opened --> Starting
Feb 5 11:18:38 	mpd: [pppoe] LCP: LayerStart
Feb 5 11:18:38 	mpd: [pppoe] LCP: LayerFinish
Feb 5 11:18:38 	mpd: [pppoe] LCP: peer not responding to echo requests
Feb 5 11:18:38 	mpd: [pppoe] LCP: no reply to 5 echo request(s)
Feb 5 11:18:28 	mpd: [pppoe] LCP: no reply to 4 echo request(s)
Feb 5 11:18:18 	mpd: [pppoe] LCP: no reply to 3 echo request(s)
Feb 5 11:18:08 	mpd: [pppoe] LCP: no reply to 2 echo request(s)
Feb 5 11:17:58 	mpd: [pppoe] LCP: no reply to 1 echo request(s)

Many, many thanks in advance, :) Nick