[ previous ] [ next ] [ threads ]
 
 From:  Chris Taylor <chris at x dash bb dot org>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  PPTP with Windows XP on 1.21
 Date:  Thu, 09 Feb 2006 21:34:22 +0000
Hi all,

First of all - PLEASE respond to this thread if you are currently using 
m0n0 as a PPTP server; I would very much like to hear from you! Please 
also mention what other features you use; I'm using Traffic Shaping, 
Captive Portal, DNS Forwarder, SNMP, Syslog support, DHCP Server and IPSec.

I am totally unable to make PPTP work with 1.21. I had it functioning on 
1.20 but on 1.21, I get nothing. I've asked several friends to try it, 
with no luck whatsoever.

At my end, I'm behind a m0n0wall and would like to use PPTP to connect 
to a remote 'wall. This does not work (this is the exact setup that 
worked before). I'm also trying to enable m0n0's PPTP server on my 
m0n0wall to allow others to connect - this does not work either.

I've followed the instructions in the FAQs, fiddled with all of the 
Windows settings and the best I can get is Windows alternating between 
errors 651, 678 (a friend gets this one intermittently) and 800. I've 
tried using subnets for PPTP clients such that they overlap with my LAN 
(no joy) and such that they overlap nothing (again, no joy). I have an 
any -> any firewall rule for PPTP clients. I've cleared NAT tables and 
rebooted machines (I have seen references to both of these working). 
I've Googled and read from the list over the past 2 years, and found 
hardly any useful information.

I've tried setting it all up from scratch several times, either 
following the FAQ or just randomly setting stuff. I'm at my wits' end 
here tbh, I just cannot see why this isn't working!

Please help...

Chris Taylor

PS: I also have a funny feeling that if I downgrade to 1.20, it isn't 
going to work either. Has anything actually changed that would affect 
PPTP between these versions?