[ previous ] [ next ] [ threads ]
 
 From:  "m0n0" <mono at gmitec dot com>
 To:  <m0n0wall at lists dot m0n0 dot ch>
 Subject:  Strange IPSec VPN problem -- Telnet get hang at the same place everytime!
 Date:  Fri, 23 Jun 2006 16:42:11 +0800
Dear all,

I am new to monowall and this is my first time message to this ML. I got a
serious problem so want some advise or experience urgently.

My company use a text based ERP. We use telnet or SSH to connect the remote
site server usually. But since telnet is so insecure through net so I tried
to set an IPSec VPN between two offices. I found that if I use
monowall-monowall IPSec or monowall-Sonicwall IPSec VPN, the user will get
hang up at the EXACT SAME SCREEN POSITION (character) when telnet login ERP
and enter a function. If, with the same connection, I use SSH instead of
telnet, I will not got hang at the same place but others place will. But if
I try Sonicwall-Sonicwall IPSec VPN, it won't has any poblem at all. I found
this problem before monowall v1.2. Then I re-try it recenlty with v1.2.2 but
the problem still exist. I found this problem can be reproductable so I
thought I will able to find some information about this problem in google
but no luck. Anyone encountered this before?

I tried different telnet clients (netterm, putty, etc) and got the same
result. I found that when the ERP hang, the telnet session is still alive. I
need to close the telnet client manually otherwise I still find the user
session by "who | sort". Will there be any special character that, after
encrypted by mono IPSec, will close telnet sesssion hang up (with
disconnect)? I tried all encryption combination but got the same result.
Anyway I can help to diagnostic it?

Thank you very much! I really need your help! THanks!

Best regards,
Johnny