[ previous ] [ next ] [ threads ]
 
 From:  "Matt Smith" <msmith at itechnetsystems dot com>
 To:  "Tim Nelson" <tnelson at fudnet dot info>
 Cc:  <m0n0wall at lists dot m0n0 dot ch>
 Subject:  RE: [m0n0wall] Nokia IP330... Two port Ethernet Addon Card
 Date:  Mon, 10 Jul 2006 00:03:08 -0400
Tim Nelson wrote:
> Hello! Yes... I am starting another thread for a Nokia IP3xx box... I 
> currently have two of them! (See my other thread regarding an
IP380...)  
> ;-)  I've installed monowall AND pfSense on this box. Both see the
three 
> ports labeled eth-s(4-5) as fxp0-2. I also have an addon card for the 
> expansion slot with two additional ports on it. These are recognized
as 
> dc0-1. However, when I plug in a cable to either of these three ports,
I 
> am not getting any link lights. I've tried connecting these ports to 
> another switch with a straight through cable as well as a crossover...

> If the card was bad I'm assuming it wouldn't be recognized by 
> mono/pfsense... my only conclusion thus far would be simply both ports

> are bad... Does anyone have any other ideas?
>
> --Tim Nelson


I have a few IP330s and IP440s and have run into the same problem. Most
likely your two port add-in card is good. The loss of link is the result
of a driver issue with the FreeBSD 4.x DC driver and the various Znyx
NICs that Nokia supplies with its IP series appliances. 

Znyx has a FreeBSD 4.0 driver available for download from their web
site. The downside is that you have to remove the DEC (DC) driver and
build the Znyx driver into the kernel.
http://www.znyx.com/support/drivers/ZX422_drivers.htm

The newer versions of FreeBSD may work with these NICs. You may want to
try pfSense.

-Matt Smith