[ previous ] [ next ] [ threads ]
 
 From:  Chris K Ellsworth <ckellsworth at yahoo dot com>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Re: [m0n0wall] Passive ftp problem
 Date:  Tue, 15 Aug 2006 16:40:59 -0700
did you tell cuteftp to use passive mode?
On Aug 15, 2006, at 3:43 PM, David Kitchens wrote:

> Guys, I know this has been hashed out MANY times but I am still  
> stuck. I've
> recently moved a MS 2003 server behind my m0n0wall, it has a static ip
> configured under Server NAT and its got a Proxy Arp setting as  
> well. Ports
> 80, 443, 25, and 110 work with no problems, port 20 and 21 are  
> mapped for
> ftp tho I don't think I need 20 as msftp runs on 21. External ip is
> x.x.x.107 and internal ip is 192.168.16.107. I have set the ftp  
> service to
> use 5500-5700 per http://support.microsoft.com/Default.aspx? 
> id=555022 and
> created an Inbound NAT entry and Rule pointing that range to the  
> internal
> ip. I can connect to the ftp server without a problem from the  
> outside but I
> get an Error: Failed to establish data socket, Trashed response  
> received,
> 425 Can't open data connection. No directory listing can be shown.  
> I am
> using Cute FTP when trying to connect but I don't think that has  
> anything to
> do with it. Attempted to connect using IE as well and get no  
> listing, tried
> setting IE to not use Passive connection and still get errors.
>
> Does anyone use passive ftp with a 2003 server? Can someone tell me  
> WTF I am
> missing please?
>
> Dave