[ previous ] [ next ] [ threads ]
 
 From:  Guy Boisvert <boisvert dot guy at videotron dot ca>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Desperate on VLAN Config!
 Date:  Tue, 03 Oct 2006 00:24:24 -0400
Hi all!

    I need to configure my Wrap SBC (3 ether) to interface an HP switch 
using 802.1Q.  For the last 2 days, i Googled a lot and even tried the 
mOnOwall forum archive without luck.  I've seen a couple of times an URL 
which seems to contain the information i seek:

http://wiki.m0n0.ch/wikka.php?wakka=VLAN

Problem is that i get the error:

Query failed: select * from wikka_pages where tag = 'VLAN' and latest = 
'Y' limit 1 (Can't open file: 'wikka_pages.MYI' (errno: 145))


Details:
=====
Version: 1.22 built on Sun Apr 2 18:57:14 CEST 2006
Platform: wrap (3 ether)
LAN    sis0
WAN    sis1
OPT    sis2


http://192.168.1.1/interfaces_vlan.php
======================================
I have created VLANs:

sis0     1
sis0     2
sis0     3
sis0     4
sis0     10





http://192.168.1.1/exec.php
===========================
$ ifconfig -a
sis0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=40<POLLING>
    inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
    ether 00:0d:b9:04:b0:48
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
sis1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=40<POLLING>
    inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
    ether 00:0d:b9:04:b0:49
    media: Ethernet autoselect (none)
    status: no carrier
sis2: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 1500
    options=40<POLLING>
    ether 00:0d:b9:04:b0:4a
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet 127.0.0.1 netmask 0xff000000
vlan0: flags=8842<BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:0d:b9:04:b0:48
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    vlan: 1 parent interface: sis0
vlan1: flags=8842<BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:0d:b9:04:b0:48
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    vlan: 2 parent interface: sis0
vlan2: flags=8842<BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:0d:b9:04:b0:48
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    vlan: 3 parent interface: sis0
vlan3: flags=8842<BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:0d:b9:04:b0:48
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    vlan: 4 parent interface: sis0
vlan4: flags=8842<BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 00:0d:b9:04:b0:48
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    vlan: 10 parent interface: sis0


So basically, it's very easy to create VLANs with the WEBGUI but i don't 
know how to enter the ip address of each VLAN interface.  Of course, i 
cannot test beacause interfaces have no ip address.  There is no way to 
enter IP address in  http://192.168.1.1/interfaces_vlan.php , neither in 
http://192.168.1.1/interfaces_lan.php (in this page, i have only one 
line asking for an IP address).

So if somebody could help me, it would be VERY cool!  I'm in a situation 
where i was supposed to configure a brand new firewall (A Snapgear 560) 
for a client, but we still don't have it and as a replacement, i will 
send my test WRAP firewall.  I have to ship the WRAP by wednesday...  My 
WRAP does the job great in my lab but i never had the chance to test 
802.1Q before.  Now i have to do it fast and i don't have any 
documentation at hand!

Well, thanks in advance for any help!

Guy Boisvert