[ previous ] [ next ] [ threads ]
 
 From:  mtnbkr <waa dash m0n0wall at revpol dot com>
 To:  Brian Quinn <bquinner at hotmail dot com>
 Cc:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Re: [m0n0wall] monowall locking up
 Date:  Mon, 09 Oct 2006 09:44:41 -0400
Brian Quinn wrote:
> Hi,
> 
> Just wondering if the lockup problem will be fixed in the next release
> and is there a timeframe for the next release.
> 
> My monowall firewall can lockup a day after rebooting but it usually
> lasts a week. It locks up on PC and wrap platfroms. It locked up with
> release 1.22, I went back to 1.21 and it locked up too. I am now using
> 1.23b1 but I reboot it manually twice a day so I dont know if 1.23b1
> locks up yet.


Brian, this is not an attack on you or anyone else that has been
experiencing and reporting these issues. I am sincerely curious about
this since if there is a common cause or condition and/or a reliable way
to produce these issues, I can test for the offending condition(s) if I
suddenly see my clients having similar problems.


I have been watching this thread for quite some time now and thought I
would chime in with my experience(s).

I have installed and support approx (10) m0n0-on-WRAP for myself and my
clients (one is on a PC), and have never once seen any of them hang for
any reason. They run for days, weeks, and months at a time without problems.

Some notes:
- All except for (2) are v1.22 (no lockups with previous versions)
- All except for (2) are on 3-port WRAPs, one is a PC, one is on a
  2-port WRAP
- Some only serve as end-points of a site-to-site VPN
- Some are just simple NAT firewalls for small networks
- Some are only VPN endpoints for PPTP road-warriors
- Some are on cable modem connections
- Some are on DSL
- Some are on T1

A somewhat special case is my office m0n0:

- It is m0n0 v1.22, on a WRAP, connected to a cablemodem and is
  configured as a VPN endpoint between my office LAN and several
  of my clients' LANs (m0n0-on-wraps at all of them).
- It is also configured with 4 VLANS and it's LAN port is connected to a
  Nortel 450 with VLAN tagging for all 4 VLANS on that port.
- Its 3rd port is configured as a DMZ
- DNS Forwarding is enabled
- Dynamic DNS (using dyndns.org) is enabled
- DHCP forwarding is enabled for 2 of the 4 VLANs


I have yet to see this thing (or any of my other installs) hang as
people are describing and I am assuming that the setup described above
is somewhat more complex than most are using.

If there is some reliable method to reproduce these m0n0 hangs I'd be
happy to try it to help make m0n0wall better, but currently, and for the
past couple years, I have yet to experience this issue.

Thanks to everyone for listening, and for any comments.

Final thought: Has anyone attempted to compare/contrast the COMPACT
FLASH cards that people are using to determine if that might be an issue?

--
Bill Arlofski
Reverse Polarity
waa dash m0n0wall at revpol dot com
* Stop the NSA from eavesdropping on your personal email *
Learn about PGP and start encrypting your email today
http://gnupg.org or http://www.pgp.com
--- We have always been at war with IRAQ ---