[ previous ] [ next ] [ threads ]
 
 From:  "Holger Bauer" <Holger dot Bauer at citec dash ag dot de>
 To:  "Rhon-Kaniel Bramwell" <rhonkaniel at anngel dot com>, "DOYELLE Vincent" <V dot DOYELLE at esc dash chambery dot fr>, <m0n0wall at lists dot m0n0 dot ch>
 Subject:  RE: [m0n0wall] CPU load and Captive portal
 Date:  Sat, 6 Jan 2007 02:18:39 +0100
Please stand by, we (pfSense team) are observing the issue. Might be
related to the webserver as it is different between m0n0 and pfSense. 

Holger 

-----Original Message-----
From: Rhon-Kaniel Bramwell [mailto:rhonkaniel at anngel dot com] 
Sent: Friday, January 05, 2007 6:59 PM
To: 'DOYELLE Vincent'; m0n0wall at lists dot m0n0 dot ch
Subject: RE: [m0n0wall] CPU load and Captive portal

I used to have that exact same problem with pfsense using a WRAP board
to do Captive Portal as well as serving as the access point, cpu load
(266MHz) and memory (128MB) was consumed totally... However when I
switched over to m0n0wall I had no more problems with either of these.

Not sure why PHP in pfsense sucks the hell outta the resources out of
anything...

My Max Number of uers on my CP was 50, simultaneous around 30.


Rhon


-----Original Message-----
From: DOYELLE Vincent [mailto:V dot DOYELLE at esc dash chambery dot fr]
Sent: Friday, January 05, 2007 12:29 PM
To: m0n0wall at lists dot m0n0 dot ch
Subject: [m0n0wall] CPU load and Captive portal

Hi all

I've tried Pfsense as a captive portal in order to authenticate my wifi
users. About 400 users are able to access internet with wifi. I've seen
on captive portal about 180 users connected simultaneoulsy.
I've observed many problems concerning cpu load : cpu load was often at
70% to 100% with MANY PHP process running.
I've tried with 3 diffrent platforms :=20

1.	P4 1.8 Ghz, 512 Mo, 60 Go=20
2.	Athlon 64 2 Ghz, 512 Mo, 80 Go (HP DX 5150)=20
3.	P3 933 Mhz, 1 Go, 72 Go (HP Proliant ML 330)

On these 3 platforms, I've observed the cpu load problems mentionned
above. On platform 2, I've observed many crash due to swap full. Trird
to change memory stick but same thing. So I've concluded that Athlon 64
was supported very well.

But, my main problem remain the cpu load. VERY often per day, I'cve seen
cpu lopad around 80% to 100%.
On all three platforms, I've seen that CPU load is very often VERY high
(between 80% to 100%). When CPU is so high, with a top command, I've
seen that there were many PHP processes consumming the cpu load.
When It's 100%, users can not access the authentification page or it's
EXTREMELY SLOW.

I've already tried to ask for help on Pfsense forum but one the forums
administrator told me to ask questions here because captive portal was a
simple port of M0n0.

So, is there any other users who have encountered these problems ?
If so, what are your number of users (max and simultaneoulsy) ?
Can Captive portal authenticate more than one user at the same time ?
Do you think that this is my problem ?

Any way, thanks all for your great job.
Thanks in advance for your help.

Regards

Vincent DOYELLE


---------------------------------------------------------------------
To unsubscribe, e-mail: m0n0wall dash unsubscribe at lists dot m0n0 dot ch
For additional commands, e-mail: m0n0wall dash help at lists dot m0n0 dot ch


__________ NOD32 1958 (20070105) Information __________

This message was checked by NOD32 antivirus system.
http://www.eset.com



---------------------------------------------------------------------
To unsubscribe, e-mail: m0n0wall dash unsubscribe at lists dot m0n0 dot ch
For additional commands, e-mail: m0n0wall dash help at lists dot m0n0 dot ch