[ previous ] [ next ] [ threads ]
 
 From:  "Neil A. Hillard" <m0n0 at dana dot org dot uk>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Re: [m0n0wall] 1.3b4 WiFi still doesnt work if LAN is down
 Date:  Fri, 16 Nov 2007 00:40:53 +0000
>>In message <1195171523 dot 9639 dot 3 dot camel at 70ph3r dot local>, Chris Flugstad
>><chris at cascadelink dot com> writes
>>>i bridge teh wifi with the LAN, but if i dont have anything plugged into
>>>the LAN, like fora  HOTSPOT, the wifi doesnt issue dhcp.  Is there a
>>>different setup for this, to work around?  other than pluggin in a
>>>switch to just "make the port active"?
>>
>>If you're not going to have anything plugged into LAN then why do you
>>need to bridge the wifi interface to it?  Can you not just run it as a
>>separate interface and add the appropriate rules to allow outbound
>>access?
>
>that should work,
>
>how might my firewall rules look?  im kinda new to this

Just copy the existing rule for LAN but on OPT1 (or whatever you call
the interface.  Go in to Rules, then LAN, click the '+' next to the
default rule, change the interface to 'OPT1' and Source Type to 'OPT1
Subnet' and change the description then that's it!  You may need to tick
'Allow fragmented packets' but leave it off to start with.

If you want to restrict what the users can do then you'll need to add in
individual rules and change the destination address and port range to
suit.

HTH,


                                Neil.

-- 
Neil A. Hillard                E-Mail:   m0n0 at dana dot org dot uk