[ previous ] [ next ] [ threads ]
 
 From:  VorsichtFalle <vorsichtfalle at arcor dot de>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Re: [m0n0wall] Emule Low ID and KAD firewalled with 1.3b9
 Date:  Sun, 03 Feb 2008 14:42:34 +0100
Michele said the following on 02/02/2008 03:13 PM:
> Hi.
> I've been using m0n0wall for a couple of years and I'm very happy with 
> this strong no-cost firewall.
> I've a little LAN with m0n0wall and 2 other pc and I'm a usual Emule user.
> The firewall is properly configured with forwarded ports and so on. I 
> never had low id or kad firewalled.
> I've used version 1.3b4 for a long time (it was released on August 2007) 
> and I wanted to try version 1.3b9.
> Well, since I booted up my firewall with the new version I always have 
> low id and kad firewalled. No configuration setting has been changed and 
> the config file in the floppy disk is always the same. Then I tried to 
> boot up again with the old version (1.3b4) and I have high id and kad 
> connected (not firewalled).
> I think there must be something with the new beta version that doen't 
> permit my emule to connect correctly, maybe a bug, a fix to be done or 
> something I should select, activate, I don't know.
> 
> So, how can I have my hi id and kad not firewalled with the version 1.3b9??
> 
> Thanks a lot.
> 
> Michele.

Hi Michele,

i encountered a similar problem (at least for the KAD protocol, ED2K 
working fine but KAD firewalled) and the solution was pretty simple. I 
followed this advice 
http://www.amule.org/wiki/index.php/FAQ_eD2k-Kademlia#Why_does_Kademlia_still_say_it_is_.22firewalled.3F.22

and now my KAD is not firewalled anymore. Just enable advanced outbound 
NAT (under Firewall/NAT/Outbound), add a rule for the ip/subnet which 
should not do portmapping and voila, it should work like a charm. At 
least it worked for me, i am using m0n0 1.3b7. HTH!
-- 
Cheers,
Lars