[ previous ] [ next ] [ threads ]
 
 From:  "Paul Rae" <paul at impacttrainingsolutions dot co dot uk>
 To:  <m0n0wall at lists dot m0n0 dot ch>
 Subject:  m0n0wall + ifgraph monitoring
 Date:  Sun, 3 Feb 2008 23:28:15 -0000
OK I think I may be going mad!! I have been using ifgraph and m0n0wall for years without any
problems.
 
The disk in my logging server was dying so i decided to setup a spare 4801 with debian to take over
its function. Got debian up and running on it, but have spent the past 2 hours failing to get
ifgraph working again.
 
find-if.pl - works fine and lists all interfaces as expected
ifgraph.pl - works without any errors
makegraph.pl -fails not matter what with the following errors:
 
torrents:~/tmp/ifgraph-0.4.10# ./makegraph.pl -c /etc/ifgraph.conf
ERROR: Garbage ': 20000000 - 1000000 bits/sec \l' after command:
COMMENT:Max bits for target router: 20000000 - 1000000 bits/sec \l
ERROR: Garbage ': 20000000 - 1000000 bits/sec \l' after command:
COMMENT:Max bits for target router: 20000000 - 1000000 bits/sec \l
ERROR: Garbage ': 20000000 - 1000000 bits/sec \l' after command:
COMMENT:Max bits for target router: 20000000 - 1000000 bits/sec \l
ERROR: Garbage ': 20000000 - 1000000 bits/sec \l' after command:
COMMENT:Max bits for target router: 20000000 - 1000000 bits/sec \l

I have copied the old config file from my old server, I have recreated the config file from scratch,
have used the default one included and still get this error. Really have no idea what I am doing
wrong as it just works on the old box.
 
I have followed the guide at: http://doc.m0n0.ch/handbook/thirdparty-ifgraph.html to ensure I'm not
making any obvious errors but still get this problem.
 
Has anyone else experienced this?
 
Any help would be great.....
 
THanks
 
 
Regards,

Paul Rae
Business Development Director

Impact Training Solutions
Geddes House
Kirkton North
Livingston
West Lothian, EH54 6GU

Mobile : 07769 654302
Email  : paul at impacttrainingsolutions dot co dot uk