[ previous ] [ next ] [ threads ]
 
 From:  Bob Gustafson <bobgus at rcn dot com>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  RE: [m0n0wall] Writing CF cards under Vista
 Date:  Sat, 16 Feb 2008 12:04:38 -0600
Are you doing any mount/umount? When I umount a CF disk (not using
physdiskwrite or Vista though), the disk writer light blinks for awhile
- leading me to believe that the last buffer(s) were being written out.
Vista has a bigger RAM footprint - maybe all the CF info is in a
buffer..

On Sat, 2008-02-16 at 15:05 +0000, Chris Bagnall wrote:
> > Did you ever manage to solve this problem? I am having extreme problems with
> > Vista and physdiskwrite and Vista.
> 
> No, in the end I just fired up my old XP laptop and used that.
> 
> I've done a little more testing today, and it doesn't work on either my desktop (Vista Business
x64 w/ USB card reader), nor my laptop (Vista Business x86 w/ PCMCIA card reader).
> 
> I've tried a multitude of CF cards ranging from 128MB up to 2GB, none of which seem to write.
> 
> Referring back to my original post, although physdiskwrite claims to have written 16384 bytes, the
access light on the CF reader never kicks in at all, which makes me wonder whether it's ever even
started writing to the card.
> 
> > run command console as admin then access physdiskwrite from there.
> 
> That's one of the things I tried at the time - no difference.
> 
> It's entirely possible it's down to a weirdness with my setup (but does seem strange that it
affects the desktop and laptop in exactly the same manner).
> 
> Oh well, the desktop's due an upgrade (and inevitably a reformat) at some point in the next month
or so, will make a point of trying it after that.
> 
> Regards,
> 
> Chris