[ previous ] [ next ] [ threads ]
 
 From:  Lee Sharp <leesharp at hal dash pc dot org>
 To:  "m0n0wall at lists dot m0n0 dot ch" <m0n0wall at lists dot m0n0 dot ch>
 Subject:  Re: [m0n0wall] Captive Portal disconnecting users
 Date:  Sun, 03 May 2009 21:37:20 -0500
Mike wrote:
> 
> Hi, i'm brand new to the mailing list but have searched google over
> including anything in the lists that returns "captive portal" and have not
> found any solution or similar situation. 
> 
> I have been using m0n0wall for a while now and have a number of machines
> using it (> 20). using a Soekris net4801 and a simple access point. I have
> experienced issues with keeping a user connected for more than a minute.
> After altering the settings to mostly every combination, i have noticed no
> change in average time the user is allowed access. This includes
> enable/disabling mac filtering, concurrent connections, concurrent logins,
> hard / idle timeouts, bandwidth limiting, logout popup (which doesn't come
> up either way). Problem persists using "no authentication" and "local
> users", radius auth methods have not been tested. Also this occurs using
> direct connections to the interface as well as access point usage. 

I guess I know it about as well as anyone.  One problem you may have is 
DHCP addresses that expire before captive portal sessions.  A new user 
on an IP with an open captive portal session can cause unexpected problems.

But right now I am shooting in the dark.  When a user fails what do you 
see for them in the;
1) Arp table
2) DHCP leases
3) Status captive portal

And what settings do you have off stock. (Allowed IPs mac filters, 
traffic shaping, firewall rules)

			Lee