[ previous ] [ next ] [ threads ]
 
 From:  Jack <list dash monowall at jack dot org dot uk>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Re: ath, bridge, and dhcp... am i missing something?
 Date:  Wed, 23 Sep 2009 10:37:16 +0100
Sorry for not being able to reply to the actual thread - I've only  
just started using M0n0!
For reference, the previous thread is in the archive, starting at :  
http://m0n0.ch/wall/list/showmsg.php?id=359/64 and ending at  
http://m0n0.ch/wall/list/showmsg.php?id=359/85

I have exactly the same problem, though I do have a little more info about it.

When the bridge is running, I do have a bridge0 interface defined in ifconfig.

My firewall rules were set to allow anything from the OPT1 interface  
to anywhere, yet DHCP traffic is being dropped.

In the firewall log, it is recording the dropped packets as 0.0.0.0:68  
-> 255.255.255.255:67.

I assume that the firewall code is getting confused over the use of  
the temporary and broadcast addresses. I have tried setting an  
explicit rule to allow this traffic to no avail.
Manually setting an IP allows communication across the bridge, so it  
is clearly something specific to DHCP traffic (again I am assuming the  
addesses used). As a work-around, I am routing between the LAN and OPT  
interfaces and have m0n0's DHCP server listening on OPT. I was unable  
t odo much more in the way of testing last night due to irate family  
members being unable to access the net while I'm tinkering ;)

Anyways, thanks for a great product, it sure beats the hell out of my  
old homebrew set-up!

Jack

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.