[ previous ] [ next ] [ threads ]
 
 From:  "David Kitchens" <spider at webweaver dot com>
 To:  <m0n0wall at lists dot m0n0 dot ch>
 Subject:  CF Failure?
 Date:  Thu, 18 Nov 2010 23:14:38 -0500
Hi all, 

 

I've got a net45xx unit at a clients that I just upgraded to 1.32, the
upgrade went fine but my vpn to it would not come up after it rebooted.

After driving to the site I found the unit to be up and running just fine.

Everything looked good when I got into the GUI but the vpn wasn't passing
traffic. I hit the Save button on the ipsec page to restart raccoon and got
this error on a blank white page:

 

Warning: filemtime(): Stat failed for /conf/config.xml (errno=2 - No such
file or directory) in /etc/inc/config.inc on line 154 Warning:

fopen(/cf/conf/config.xml): failed to open stream: No such file or directory
in /etc/inc/config.inc on line 655 Unable to open config.xml for writing in

write_config()

 

I could go back a page and hit any other page but that error kept coming up
at the top of every page. I was able to download the config, it looked fine,
it uploaded fine and rebooting cleared the error. Until I tried to make
another config change. Same error, rebooting cleared it once again. I am
assuming that it is an upcoming failure of the CF card? That part is easy to
do if that is the case. 

 

The confusing part is why the vpn is acting strange, the logs said the vpn
was up, it had SAD and SPD entries, but I could not ping my home office
m0n0wall. I gave up on that as I didn't need to access home from the client
but when I got home, the vpn was up and I can access their computers just
fine! Has anyone seen a one-way vpn before? I can ping the client but client
can't ping me???

 

Dave