[ previous ] [ next ] [ threads ]
 
 From:  Joe Cavaliere <joe at trans dash plus dot com>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  VMware + Monowall = FTP not working
 Date:  Mon, 6 Feb 2012 13:22:50 -0500
I have 2 identical setups.

1) Physical machine running monowall 1.33
2) VMware Image running monowall 1.33

Note that the configurations are identical. This is not a PASV or ACTIVE
FTP problem.

The problem I have is when trying to access an FTP server OUTSIDE my
network with the VMWARE image.
CommandLine FTP or any FTP client says  "connected" but locks there, the
welcome login screen never appears and eventually times out and
disconnects.
PASV and ACTIVE setups don't change a thing.

When I try this on the physical machine it works.

I've scoured the internet for a solution for the past year (i've attempted
finding a solution several times before with no success. )
The problem exists only when trying to access FTP through Monowall on a
VMWARE image.

- I can successfully connect to FTP on a  Virtual Machine bypassing Monowall
- I can successfully connect to FTP on a physical machine going through
Monowall
- I CANNOT connect to FTP on a Virtual Machine going through Monowall.

Hopefully some one has come across and found this a solution to this. I
know im not the only person experiencing this:

other people experiencing this issue.
- http://forum.m0n0.ch/index.php/topic,4442.msg16080.html
- http://communities.vmware.com/thread/334796

*I've played around with the 'promiscuous mode' settings in vmware with no
success either.
Perhaps im missing something although the post doesn't state that this
resolves the FTP issue.

Please