[ previous ] [ next ] [ threads ]
 
 From:  =?ISO-8859-15?Q?Michael_M=F6sl?= <michaelmoesl at gmx dot at>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  No connection to ISP using PPTP with 1.8.1
 Date:  Mon, 20 Jan 2014 19:31:47 +0100
Hi there!

After updating my M0n0wall from 1.34 to 1.8.1 i'm not able to connect to
my ISP using PPTP anymore.

Here is a example of a failed connection try:
Jan 1 01:04:03     mpd: [L1] Link: reconnection attempt 11
Jan 1 01:04:03     mpd: [L1] PPTP call successful
Jan 1 01:04:03     mpd: [L1] Link: UP event
Jan 1 01:04:03     mpd: [L1] LCP: Up event
Jan 1 01:04:03     mpd: [L1] LCP: state change Starting --> Req-Sent
Jan 1 01:04:03     mpd: [L1] LCP: SendConfigReq #37
Jan 1 01:04:03     mpd: [L1] ACCMAP 0x000a0000
Jan 1 01:04:03     mpd: [L1] MRU 1500
Jan 1 01:04:03     mpd: [L1] MAGICNUM e900009a
Jan 1 01:04:05     mpd: [L1] LCP: SendConfigReq #38
Jan 1 01:04:05     mpd: [L1] ACCMAP 0x000a0000
Jan 1 01:04:05     mpd: [L1] MRU 1500
Jan 1 01:04:05     mpd: [L1] MAGICNUM e900009a
Jan 1 01:04:05     mpd: [L1] LCP: rec'd Configure Request #53 (Req-Sent)
Jan 1 01:04:05     mpd: [L1] MRU 1500
Jan 1 01:04:05     mpd: [L1] AUTHPROTO CHAP MD5
Jan 1 01:04:05     mpd: [L1] MAGICNUM 6d8225be
Jan 1 01:04:05     mpd: [L1] LCP: SendConfigAck #53
Jan 1 01:04:05     mpd: [L1] MRU 1500
Jan 1 01:04:05     mpd: [L1] AUTHPROTO CHAP MD5
Jan 1 01:04:05     mpd: [L1] MAGICNUM 6d8225be
Jan 1 01:04:05     mpd: [L1] LCP: state change Req-Sent --> Ack-Sent
Jan 1 01:04:05     mpd: [L1] LCP: rec'd Configure Reject #38 (Ack-Sent)
Jan 1 01:04:05     mpd: [L1] ACCMAP 0x000a0000
Jan 1 01:04:05     mpd: [L1] LCP: SendConfigReq #39
Jan 1 01:04:05     mpd: [L1] MRU 1500
Jan 1 01:04:05     mpd: [L1] MAGICNUM e900009a
Jan 1 01:04:05     mpd: [L1] LCP: rec'd Configure Ack #39 (Ack-Sent)
Jan 1 01:04:05     mpd: [L1] MRU 1500
Jan 1 01:04:05     mpd: [L1] MAGICNUM e900009a
Jan 1 01:04:05     mpd: [L1] LCP: state change Ack-Sent --> Opened
Jan 1 01:04:05     mpd: [L1] LCP: auth: peer wants CHAP, I want nothing
Jan 1 01:04:05     mpd: [L1] LCP: LayerUp
Jan 1 01:04:05     mpd: [L1] CHAP: rec'd CHALLENGE #1 len: 28
Jan 1 01:04:05     mpd: [L1] Name: "Name"
Jan 1 01:04:05     mpd: [L1] CHAP: Using authname "Username"
Jan 1 01:04:05     mpd: [L1] CHAP: sending RESPONSE #1 len: 31
Jan 1 01:04:05     mpd: [L1] CHAP: rec'd SUCCESS #1 len: 31
Jan 1 01:04:05     mpd: [L1] MESG: CHAP authentication success
Jan 1 01:04:05     mpd: [L1] LCP: authorization successful
Jan 1 01:04:05     mpd: [L1] Link: No actions defined
Jan 1 01:04:05     mpd: [L1] No bundle specified
Jan 1 01:04:05     mpd: [L1] link did not validate in bundle
Jan 1 01:04:05     mpd: [L1] LCP: parameter negotiation failed
Jan 1 01:04:05     mpd: [L1] LCP: state change Opened --> Stopping
Jan 1 01:04:05     mpd: [L1] LCP: SendTerminateReq #40
Jan 1 01:04:05     mpd: [L1] LCP: LayerDown
Jan 1 01:04:05     mpd: [L1] rec'd proto IPCP during terminate phase
Jan 1 01:04:05     mpd: [L1] LCP: rec'd Terminate Ack #40 (Stopping)
Jan 1 01:04:05     mpd: [L1] LCP: state change Stopping --> Stopped
Jan 1 01:04:05     mpd: [L1] LCP: LayerFinish
Jan 1 01:04:05     mpd: [L1] PPTP call terminated
Jan 1 01:04:05     mpd: [L1] Link: DOWN event
Jan 1 01:04:05     mpd: [L1] LCP: Down event
Jan 1 01:04:05     mpd: [L1] LCP: state change Stopped --> Starting
Jan 1 01:04:05     mpd: [L1] LCP: LayerStart

After downgrading it back to 1.34 the connection was successfully
established.
Jan 1 01:24:25     mpd: [pptp] LCP: SendConfigReq #2
Jan 1 01:24:25     mpd: ACCMAP 0x000a0000
Jan 1 01:24:25     mpd: MRU 1500
Jan 1 01:24:25     mpd: MAGICNUM 5da2a6a2
Jan 1 01:24:25     mpd: [pptp] LCP: rec'd Configure Request #150 (Req-Sent)
Jan 1 01:24:25     mpd: MRU 1500
Jan 1 01:24:25     mpd: AUTHPROTO CHAP MD5
Jan 1 01:24:25     mpd: MAGICNUM 6a9ed980
Jan 1 01:24:25     mpd: [pptp] LCP: SendConfigAck #150
Jan 1 01:24:25     mpd: MRU 1500
Jan 1 01:24:25     mpd: AUTHPROTO CHAP MD5
Jan 1 01:24:25     mpd: MAGICNUM 6a9ed980
Jan 1 01:24:25     mpd: [pptp] LCP: state change Req-Sent --> Ack-Sent
Jan 1 01:24:25     mpd: [pptp] LCP: rec'd Configure Reject #2 (Ack-Sent)
Jan 1 01:24:25     mpd: ACCMAP 0x000a0000
Jan 1 01:24:25     mpd: [pptp] LCP: SendConfigReq #3
Jan 1 01:24:25     mpd: MRU 1500
Jan 1 01:24:25     mpd: MAGICNUM 5da2a6a2
Jan 1 01:24:25     mpd: [pptp] LCP: rec'd Configure Ack #3 (Ack-Sent)
Jan 1 01:24:25     mpd: MRU 1500
Jan 1 01:24:25     mpd: MAGICNUM 5da2a6a2
Jan 1 01:24:25     mpd: [pptp] LCP: state change Ack-Sent --> Opened
Jan 1 01:24:25     mpd: [pptp] LCP: auth: peer wants CHAP, I want nothing
Jan 1 01:24:25     mpd: [pptp] LCP: LayerUp
Jan 1 01:24:25     mpd: [pptp] CHAP: rec'd CHALLENGE #1
Jan 1 01:24:25     mpd: Name: "Name"
Jan 1 01:24:25     mpd: Using authname "Username"
Jan 1 01:24:25     mpd: [pptp] CHAP: sending RESPONSE len:27
Jan 1 01:24:25     mpd: [pptp] CHAP: rec'd SUCCESS #1
Jan 1 01:24:25     mpd: MESG: CHAP authentication success
Jan 1 01:24:25     mpd: [pptp] LCP: authorization successful
Jan 1 01:24:25     mpd: [pptp] Bundle up: 1 link, total bandwidth 64000 bps
Jan 1 01:24:25     mpd: [pptp] IPCP: Open event
Jan 1 01:24:25     mpd: [pptp] IPCP: state change Initial --> Starting
Jan 1 01:24:25     mpd: [pptp] IPCP: LayerStart
Jan 1 01:24:25     mpd: [pptp] IPCP: Up event

I didn't changed the Config between Update and Downgrade. I tried to
restore the saved config but this also didn't fix the problem.
My ISP is the austrian provider A1 and my M0n0wall is running on an ALIX
board.
Any Ideas?

Regards
Michael