[ previous ] [ next ] [ threads ]
 
 From:  "Barry Murphy" <barry at unix dot co dot nz>
 To:  "'Chris Olive'" <chris at technologEase dot com>, "'M0n0Wall'" <m0n0wall at lists dot m0n0 dot ch>
 Subject:  RE: [m0n0wall] m0n0wall v1.0, Soekris net4511 wireless freezing?
 Date:  Sun, 25 Apr 2004 10:29:39 +1200
Chris,

I've been having the asme problem, every 5-15 days the m0n0wall freezez.
The wireless clint link stays up fine so accessing the system via the
WAN is O.K. but not when the reboot function doesn't work. When I reboot
my system it gets stuck (ONLY if I reboot or do an Upgrade) at the
following location:
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A

But this isn't my problem, I don't mind taking a drive to the wireless
site breaking into the persons garage and rebooting the system. My
problem is why does the wireless AP interface die, and why only after a
certain amount of traffic or days ? I've been running an older version
of m0n0wall but today have upgraded to version 1 as the AP died on me
last night.

The system is as follows:
Timecounter "i8254"  frequency 1193182 Hz
CPU: Pentium/P54C (99.47-MHz 586-class CPU)
  Origin = "GenuineIntel"  Id = 0x525  Stepping = 5
  Features=0x1bf<FPU,VME,DE,PSE,TSC,MSR,MCE,CX8>
real memory  = 50331648 (49152K bytes)
avail memory = 34492416 (33684K bytes)
ad0: 61MB <SanDisk SDCFB-64> [490/8/32] at ata0-master PIO1
Mounting root from ufs:/dev/md0c
pccard: card inserted, slot 0
pccard: card inserted, slot 1
pccard: card removed, slot 1
pccard: card removed, slot 0
pccard: card inserted, slot 1
pccard: card inserted, slot 0
wi0 at port 0x240-0x27f irq 15 slot 0 on pccard0
wi0: 802.11 address: 00:02:6f:08:36:9c
wi0: using RF:PRISM2.5 MAC:ISL3873
wi0: Intersil Firmware: Primary 1.01.00, Station 1.04.09
wi1 at port 0x280-0x2bf irq 10 slot 1 on pccard1
wi1: 802.11 address: 00:02:6f:07:30:9c
wi1: using RF:PRISM2.5 MAC:ISL3873
wi1: Intersil Firmware: Primary 1.01.00, Station 1.04.09

The system does the following:
- Wireless client on WAN to WISP provider.
- Wireless AP pointing towards my home.
- Advanced NAT to one ip address
- DHCP
And that's all I can recall.

Lucky for Quagga running at home with my multipath, my internet
connection doesn't go down, my bgp feed re routes traffic over my DSL.
Only problem is most clients connecting to that AP can't see the other
AP I have at home so they have to wait till I can reboot the machine
mentioned above.

I will update you and let you know how version 1 works for me.

Barry

-----Original Message-----
From: Chris Olive [mailto:chris at technologEase dot com] 
Sent: Friday, 16 April 2004 3:25 p.m.
To: M0n0Wall
Subject: [m0n0wall] m0n0wall v1.0, Soekris net4511 wireless freezing?


Hey folks,

I haven't written in a while because my m0n0wall has been working 
perfectly for months...  Until now.  All of a sudden -- with no changes 
introduced whatsoever (I've been running MW v1.0 since it first came out

several weeks ago or longer?) -- the wireless on my m0n0wall running on 
a Soekris net4511 just freezes from time to time (it's happened twice 
this week.)  I can't remember what wireless card I have in it exactly --

it's one that comes as a wireless kit specifically for the Soekris 
boards at www.netgate.com...

I know it's kinda lame to post without more concrete details, but I just

thought I would poke around and see if anyone else has experienced their

wireless interface suddenly freezing.  It's just outta the blue.  I 
scanned the mailing list and didn't see anything related.  I guess if it

continues, I'll have to break down and fully diagnoise this and provide 
more specifics but thought maybe someone would pipe in...?

Chris
-----
Chris Olive
chris at technologEase dot com


---------------------------------------------------------------------
To unsubscribe, e-mail: m0n0wall dash unsubscribe at lists dot m0n0 dot ch
For additional commands, e-mail: m0n0wall dash help at lists dot m0n0 dot ch