[ previous ] [ next ] [ threads ]
 
 From:  "Chet Harvey" <chet at pittech dot com>
 To:  "Michael Iedema" <iedemam at pluto dot dsu dot edu>, "'m0n0wall'" <m0n0wall at lists dot m0n0 dot ch>
 Subject:  Rv: [m0n0wall] pci->pcmcia adapter troubles
 Date:  Thu, 20 May 2004 16:43:05 -0100
That is a supported card. It does look like you may have an IRQ sharing
issue but these things sometimes work themselves out.

What you should do now is hook back up to your serial port and see if you
can configure the optional interface. Should be opt1.

The interface will not show up in the web GUI until you config it from the
console first.



--------- Mensagem Original --------
From: Michael Iedema <iedemam at pluto dot dsu dot edu>
To: 'm0n0wall' <m0n0wall at lists dot m0n0 dot ch>
Subject: [m0n0wall] pci->pcmcia adapter troubles
Date: 20/05/04 17:08

>
> Greetings List,
> I recently installed a pci-&gt;pcmcia into the m0n0wall box at work to add
> some wireless access to our building.  The interface didn't show up in
> the GUI so I ran dmesg to get a better idea of what was happening.
> Based on the dmesg output I believe there is an IRQ conflict but I've
> never been very good at troubleshooting hardware conflicts.  If anyone
> has any input please let me know.  The box is a bit old and that may be
> the culprit (dead pci slot or something).
>
> I switched our LAN interface and the new pci adapter around to see if
> that would fix it and then  neither interface showed up in the listing.
> So.....anyway.
>
> Thanks,
> --Michael I.
>
> ----DMESG OUTPUT-----------
>
>
> $ dmesg
> Copyright (c) 1992-2003 The FreeBSD Project.
> Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
> 	The Regents of the University of California. All rights
> reserved.
> FreeBSD 4.9-RELEASE-p4 #0: Sat Apr 17 21:05:55 CEST 2004
>     root at nb dot neon1 dot net:/usr/src/sys/compile/M0N0WALL_GENERIC
> Timecounter &quot;i8254&quot;  frequency 1193182 Hz
> CPU: Pentium II/Pentium II Xeon/Celeron (431.38-MHz 686-class CPU)
>   Origin = &quot;GenuineIntel&quot;  Id = 0x660  Stepping = 0
>
>
Features=0x183f9ff&lt;FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,C
> MOV,PAT,PSE36,MMX,FXSR&gt;
> real memory  = 100651008 (98292K bytes)
> avail memory = 83308544 (81356K bytes)
> Preloaded elf kernel &quot;kernel&quot; at 0xc0e0f000.
> Preloaded mfs_root &quot;/mfsroot&quot; at 0xc0e0f09c.
> Pentium Pro MTRR support enabled
> md0: Preloaded image &lt;/mfsroot&gt; 10485760 bytes at 0xc040da00
> md1: Malloc disk
> Using $PIR table, 9 entries at 0xc00f2250
> npx0: &lt;math processor&gt; on motherboard
> npx0: INT 16 interface
> pcib0: &lt;Intel 82443BX (440 BX) host to PCI bridge&gt; on motherboard
> pci0: &lt;PCI bus&gt; on pcib0
> pcib1: &lt;Intel 82443BX (440 BX) PCI-PCI (AGP) bridge&gt; at device 1.0
on
> pci0
> pci1: &lt;PCI bus&gt; on pcib1
> pci1: &lt;S3 Trio3D graphics accelerator&gt; at 1.0 irq 9
> isab0: &lt;Intel 82371AB PCI to ISA bridge&gt; at device 2.0 on pci0
> isa0: &lt;ISA bus&gt; on isab0
> atapci0: &lt;Intel PIIX4 ATA33 controller&gt; port 0xfff0-0xffff at device
2.1
> on pci0
> ata0: at 0x1f0 irq 14 on atapci0
> ata1: at 0x170 irq 15 on atapci0
> uhci0: &lt;Intel 82371AB/EB (PIIX4) USB controller&gt; at device 2.2 on
pci0
> uhci0: Could not map ports
> device_probe_and_attach: uhci0 attach returned 6
> chip1: &lt;Intel 82371AB Power management controller&gt; port
0xfe00-0xfe0f at
> device 2.3 on pci0
> pci_cfgintr_search: linked (62) to configured irq 9 at 0:18:0
> pci_cfgintr: 0:16 INTA routed to irq 9
> pcic0: &lt;TI PCI-1410 PCI-CardBus Bridge&gt; irq 9 at device 16.0 on pci0
> pcic0: Could not map register memory 0xf3ffc000
> device_probe_and_attach: pcic0 attach returned 12
> dc0: &lt;82c169 PNIC 10/100BaseTX&gt; port 0x7800-0x78ff mem
> 0xf3ffbf00-0xf3ffbfff irq 9 at device 18.0 on pci0
> dc0: Ethernet address: 00:02:e3:07:ca:a5
> miibus0: &lt;MII bus&gt; on dc0
> ukphy0: &lt;Generic IEEE 802.3u media interface&gt; on miibus0
> ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
> xl0: &lt;3Com 3c905C-TX Fast Etherlink XL&gt; port 0x7c00-0x7c7f mem
> 0xf3ffbe80-0xf3ffbeff irq 11 at device 20.0 on pci0
> xl0: Ethernet address: 00:04:75:c2:52:e3
> miibus1: &lt;MII bus&gt; on xl0
> ukphy1: &lt;Generic IEEE 802.3u media interface&gt; on miibus1
> ukphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
> orm0: &lt;Option ROMs&gt; at iomem 0xc0000-0xc7fff,0xc8000-0xc87ff on isa0
> pmtimer0 on isa0
> fdc0: &lt;NEC 72065B or clone&gt; at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on
> isa0
> fdc0: FIFO enabled, 8 bytes threshold
> fd0: &lt;1440-KB 3.5&quot; drive&gt; on fdc0 drive 0
> atkbdc0: &lt;Keyboard controller (i8042)&gt; at port 0x60,0x64 on isa0
> vga0: &lt;Generic ISA VGA&gt; at port 0x3c0-0x3df iomem 0xa0000-0xbffff on
> isa0
> sc0: &lt;System console&gt; at flags 0x100 on isa0
> sc0: VGA &lt;16 virtual consoles, flags=0x300&gt;
> sio0: configured irq 4 not in bitmap of probed irqs 0
> sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
> sio0: type 8250
> sio1: configured irq 3 not in bitmap of probed irqs 0
> BRIDGE 020214 loaded
> IPsec: Initialized Security Association Processing.
> IP Filter: v3.4.33 initialized.  Default = block all, Logging = enabled
> ata1-slave: ATA identify retries exceeded
> ad0: 1223MB &lt;ST51270A&gt; [2485/16/63] at ata0-master WDMA2
> acd0: CDROM &lt;CD-ROM CDU701-F&gt; at ata1-master PIO4
> Mounting root from ufs:/dev/md0c
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: m0n0wall dash unsubscribe at lists dot m0n0 dot ch
> For additional commands, e-mail: m0n0wall dash help at lists dot m0n0 dot ch
>
>
>
>
>
>
>