[ previous ] [ next ] [ threads ]
 
 From:  Marten <wleiden at xs4all dot nl>
 To:  Magne Andreassen <magne dot andreassen at bluezone dot no>
 Cc:  mono <m0n0wall at lists dot m0n0 dot ch>
 Subject:  RE: [m0n0wall] D-link DWL 650 in hostap mode?
 Date:  27 Sep 2003 10:05:59 +0200
On Fri, 2003-09-26 at 23:25, Magne Andreassen wrote:
> Marten wrote:
> > On Fri, 2003-09-26 at 18:40, Magne Andreassen wrote:
> >> Hi,
> >> 
> >> Finally got myself a net4511 box and a wireless D-link DWL 650
> >> pcmcia card. nice.
> >> 
> >> But problem is, it wont work in hostap mode. I noticed that manuel
> >> have tested this on D-link DWL 520 (PCI) witch is, same as the DWL
> >> 650 card, based on PRISM-II chipset.
> >> 
> >> Can anyone pinpoint me if i am doing something wrong with the setup,
> >> or this wont work at all because my card dont support hostap mode..
> > 
> > with dmesg | grep wi<n>  you can figger out your current firmware...
> > 
> > here you can get new firmware (at your own risk :))
> > http://www.netgate.com/support/prism_firmware/
> > 

> wi0: Intersil Firmware: Primary 0.03.00, Station 0.08.02
> 
> As far as i know, the US firmware is not safely usable for european
> products.
> I am therefor a little careful before flashing my card.
> But 0.03 and 0.08 seems pretty old firmware, does it not?

It is old, but could work fine, I am using p 0.3.0 s 0.8.0 in wl200
compaq  and dynalink L11HDT (s 0.8.3)cards. Also the 0.8.3 is known to
work. While trying upgrading one of the dynalink cards i had an error
from winupdate saing that the new firmware is will work on newer prisms
chips. So now hard was done. The is a tool for upgrading to 0.8.3 on the
intersil site. 
to make a bit more complex:

http://www.wi-fiplanet.com/tutorials/article.php/10724_2173201_2

First I would try is to install in a freebsd box to experiment with it
in combination with machine with netstumbler of kismet. 
man wicontrol will help you on 4.8. 5.0 :) 
specially: -c 1 -p 6 -n bert -q bert -c 1

0n 5.1 wicontrol is dispreciated on settings are found ( not very clear)
in man ifconfig

Marten