[ previous ] [ next ] [ threads ]
 
 From:  Joey Morin <jmorin at icomm dot ca>
 To:  Manuel Kasper <mk at neon1 dot net>
 Cc:  "Kevin R. Porter" <krp2 at bellsouth dot net>, <m0n0wall at lists dot m0n0 dot ch>
 Subject:  Re: [m0n0wall] Beta 1.1b13 --> DNS still does not work, clients get "Query refused" responses.
 Date:  Mon, 14 Jun 2004 14:37:45 -0400 (EDT)
This one time, at band camp, Manuel Kasper said:

> On 13.06.2004 23:10 -0400, Kevin R. Porter wrote:
>
> >     $ ls -al /etc/dhclient-exit-hooks
> >     -rwxr-xr-x  1 root  wheel  102 Aug 31  2003
> > /etc/dhclient-exit-hooks
>
> dhclient-exit-hooks has nothing to do with PPPoE; it is only executed
> when DHCP is used on WAN.
>
> > In hopes of giving either you or Manuel a clue as to the real cause
> > some observations / avenues for thought:
>
> Problem identified. It was caused by a change in MPD 3.18 (iface.c) -
> the missing authname is now passed to the linkup script (the MPD
> documentation always said so, but we'd found this not to be the case in
> < 3.18), so now of course all the interesting arguments to our
> ppp-linkup script (the DNS server addresses) have shifted by one. See
> <http://cvs.sourceforge.net/viewcvs.py/mpd/mpd/src/iface.c>...
>
> The fix is trivial - only need to increment $5 ... $8 in
> /usr/local/sbin/ppp-linkup by one. This will be fixed in the next
> release.

will this fix the problem i'm having with dhcp clients not being able to
resolve names through dns forwarding to the m0n0?  the only way i can get
it to work, with my pppoe wan, is if i define static dns servers in
system.php, despite the fact that my isp assings dns servers through
pppoe.

if this will in fact fix this problem, could you please post how to ticke
ppp-linkup in the proper way?  i'd like to apply the changes to my own
m0n0...

many thanks,
jj