[ previous ] [ next ] [ threads ]
 
 From:  ubi de feo <ubi at twodotone dot com>
 To:  "<m0n0wall at lists dot m0n0 dot ch> <m0n0wall at lists dot m0n0 dot ch>" <m0n0wall at lists dot m0n0 dot ch>
 Subject:  DHCP on WAN + DNS issues
 Date:  Mon, 19 Jul 2004 21:36:06 +0200
hi, ppl.
i started a thread long time ago, before giving up with m0n0wall.
now i'm trying to get challenged again.

i try to explain my problem, even though i'm not a network expert.

i have an ADSL over ISDN connection here in holland, with kpn.
the adsl modem is a speedtouch 510i (1 isdn port+1 eht port).
after ages spent on hacking the modem to have it working with DHCP 
spoofing
(all the dhcp data are passed to the first machine that requests them), 
i bought a
soekris net 4801, thinking that i could solve my problems with 
4801+m0n0wall
instead of the crappy unmanageable firewall that the speedtouch has in 
it.

well...
this was never working, mates.

whatever machine i attach to the modem gets every piece of 
configuration data.
IP
subnet
router(gateway)


now...
why doesn't m0n0wall get them?

what i get from the DHCP server is the following

IP: 213.84.x.x
subnet: 255.255.255.255
router: 195.190.249.11

when i check the interfaces panel in the web admin, i can just see that 
the WAN interface
finds the IP and the subnet.
no gateway

then, when i try pinging www.google.com, nothing comes out.
it's unreachable.

i also tried to configure the speedtouch as PPTP, but i don't have the 
"provider IP" to pptp to.

anyone has any idea on how to get out of this and live a happy life 
with my m0n0?

thanx for listening

ciao.ubi