[ previous ] [ next ] [ threads ]
 
 From:  Rainer Zocholl <UseNet dash Posting dash Nospam dash 74308 dash at zocki dot toppoint dot de>
 To:  <m0n0wall at lists dot m0n0 dot ch>
 Subject:  Re: [m0n0wall] NE2000 ISA Howto?
 Date:  08 Aug 2004 19:11:00 +0200
ayocee at gmail dot com(Kirk Lane)  08.08.04 07:53

>On 08 Aug 2004 15:02:00 +0200, Rainer Zocholl
>>
>> i'm trying to run m0n0wall under Bochs.
>> Bochs emulates an NE2000 ISA card, non-PnP, nonPCI
>> at port 0x300 irq 3
>>
>> But it seems not to be able to find that cards,
>> tho NE2000 ist listed in HCL.
>>
>> I don't see any way where i can enter the
>> network driver manually.

>http://your.m0n0wall.address/exec.php

Thanks. But i have NO network access at all
i'm stuck on the setup page!

Bochs is a x86-simulator which simulates only that kind
of ethernet cards.


>And run 'dmesg'.
>See if you can find your cards showing up, 

I see the boot messages scrolling up (it's not so fast)

>or related error messages.

There are no error messages.
(but i wonder how it could find a sio at irq3..)


Booting from Hard Disk...

BTX loader 1.00  BTX version is 1.01
Console: internal video/keyboard
BIOS drive C: is disk0
BIOS 639kB/64512kB available memory

FreeBSD/i386 bootstrap loader, Revision 0.8
(root at nb dot neon1 dot net, Sat May 29 16:47:22 CEST 2004)

/kernel text=0x2e34e0 data=0x44adc+0x231d4 syms=[0x4+0x3fd10+0x4+0x47b20]

Hit [Enter] to boot immediately, or any other key for command prompt.
{no wait occurs}
Booting [kernel]...

Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 4.10-RELEASE #0: Sun Jun 20 11:16:54 CEST 2004
    root at nb dot neon1 dot net:/usr/src/sys/compile/M0N0WALL_GENERIC
...

npx0: error reporting broken; using 387 emulator
isa0: <ISA bus> on motherboard
orm0: <Option ROM> at iomem 0xc0000-0xc7fff on isa0
pmtimer0 on isa0
fdc0: <NEC 765 or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
ata0 at port 0x1f0-0x1f7,0x3f6 irq 14 on isa0
ata1 at port 0x170-0x177,0x376 irq 15 on isa0
>{there is only one ata-controler}
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model Generic PS/2 mouse, device ID 0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
>{hm, there no serial port configured..}
sio1: configured irq 3 not in bitmap of probed irqs 0
BRIDGE 020214 loaded
IPsec: Initialized Security Association Processing.
IP Filter: v3.4.33 initialized.  Default = block all, Logging = enabled
ata0-slave: ATAPI identify retries exceeded
ad0: 9MB <Generic 1234> [20/16/63] at ata0-master BIOSPIO
Mounting root from ufs:/dev/md0c
Found configuration on ad0.
Initializing timezone... done
Initializing PC cards... failed (probably no PC card controller present)
Configuring firewall... done
Configuring LAN interface... done
Configuring WAN interface... done
Starting syslog service... done
Starting webGUI... done
Starting DNS forwarder... done
Starting NTP client... done

etc..
But no ethernet card was found!