[ previous ] [ next ] [ threads ]
 
 From:  Ganbold <ganbold at micom dot mng dot net>
 To:  "Fred Mol" <fredlist at xs4all dot nl>
 Cc:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Re: [m0n0wall] M0n0wall 1.1 problem on WRAP.1D
 Date:  Wed, 01 Sep 2004 14:29:22 +0900
Fred,

Yes, I found out the problematic line :)
I have trouble patching the FreeBSD sources using kernel-patches-410.tgz.
Some patches aren't working.
Could you give me some directions?

thanks a lot,

Ganbold

At 05:34 AM 01.09.2004, you wrote:
>Ganbold said:
> > Hi,
> >
> > I'm having trouble booting m0n0wall 1.1 on WRAP.1D.
> > I tested original wrap-1.1.img on WRAP and it is working fine. However when
> > I extract the image
> > using Michael Ledema's php script and compress it back using same script,
> > m0n0wall doesn't boot. It just hangs.
> > I need to make some modifications and that is why I have to extract the
> > image and compress it back.
>
>I assume you mean Michael Iedema's script at
>http://www.michael-i.com/files/projects/m0n0image/m0n0image_v0.1.1.phps
>It suffers from the same problem as my module installer script until
>recently: It creates a new bootable image with the boot programs from
>the host on which the script runs, while it should use the boot programs
>from the original wrap image. The offending line is this one:
>     "disklabel -BR vn0 label.proto",
>It should be something like:
>"disklabel -b $directory/boot/boot1 -s $directory/boot/boot2 -BR vn0
>label.proto",
>
> > Does anybody have this issue before on WRAP?
> > Is there any other scripts that makes correct image?
> >
>
>You could use the module installer from http://www.xs4all.nl/~fredmol/m0n0
>
>Hope this helps,
>
>--Fred
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: m0n0wall dash unsubscribe at lists dot m0n0 dot ch
>For additional commands, e-mail: m0n0wall dash help at lists dot m0n0 dot ch