[ previous ] [ next ] [ threads ]
 
 From:  "NewMedia42" <newmedia42 at excite dot com>
 To:  m0n0wall at lists dot m0n0 dot ch
 Subject:  Traffic Shaper/MRTG/IP usage question...
 Date:  Fri, 17 Sep 2004 14:33:09 -0400 (EDT)
I'm using the method outlined by John Voigt for feeding data into MRTG, basically adding a Traffic
Shaper rule for the inbound and outbound data, then using a custom php page to output the results of
ipfw show; followed by a bit of perl code on the MRTG end a voila!  IP stats!

Now, this works fine on my home deployment of mono, running on a 4801, but I just built a 3gig P4
system running the generic mono PC image and it doesn't appear to be working correctly.  When I do
the show, I see the following (I replace the first three octets with x):

50002       0         0 pipe 1 ip from x.x.x.1 to any via rl0
50003     168      4704 pipe 1 ip from any to x.x.x.1 via rl0

It obviously is tracking the data Inbound, but not Outbound.  I should also point out that I'm
trying to track this on the 3rd NIC, which I have bridged with the WAN interface, with filter bridge
enabled.  The only other interesting thing is that if I put the rule on the WAN interface then it
won't show ANY stats (this is true of my home install as well) - it only shows stats if on the LAN
or OPT interface.

Does anyone have any idea why this wouldn't work?  I'm stumped as to why it would have these
results...


_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!